Using custom build SAP 12.6 Infomaker Reports embedded into an Appeon Powerbuilder 2017 desktop app

1
0
-1

Hi,

in the past our customers used Infomaker to modify existing reports or to create their own reports with Infomaker.

The customers are able to integrate these datawindow reports created by themself into our powerbuilder desktop app.

This  is done by adding the custom infomaker pbl file in front of the library list of our desktop app on runtime!

in the past we told customers to use always same version of infomaker as we do for the pb desktop app to avoide any problems.

 

Any  remarks  about using  SAP 12.6 Infomaker to create/modify report datawindows and integrate this pbl file  ( including the reports) to an appeon pb build desktop app?

Alternative Solutions? (We are also using SSRS for customers but have a lot of long term customers using IM)

will it work for IM 12.6 and PB2017?

will it work for older IM versions, too?

will it work with newer Appeon PB versions ( appeon will remove the pbl files)?

is it OFFICAL SUPPORTED by appeon to mix SAP IM Reports with (into) Appeon PB 2017/2018 desktop app? 

 

What do other Infomaker Customers think about Infomaker ?

TIA

 

 

Question Tags: 

Answers

Chris Pollach answered Using custom build SAP 12.6 Infomaker Reports embedded into an Appeon Powerbuilder 2017 desktop app

1
0
-1

Hi Heino;

 

   The same rules and combined features will exist in IM 2017 and PB 2017. The main compatibility is within the DataWindow object but other run-time aspects (depending on what IM/PB features you use) also come into play. So keeping the product versions consistent is definitely important for both cross functionality and stability reasons.

   Just a note on older versions of IM. The SAP / Appeon agreement does not allow Appeon to support older versions of IM or PB. SAP is also EOL'ing IM & PB soon. So not only would it be dangerous to mix PB/IM versions .. if you do & things go wrong - you will not be receiving any help or fixes from Appeon on your dilemma. Also, Appeon is not testing IM compatibility below version IM 2017 - so we cannot advise you if it even works in older version combinations.

 

HTH - Regards ... Chris

Appeon: Director, Developer Relations