1. Tanya Weaver
  2. PowerBuilder
  3. Monday, 14 November 2022 12:21 PM UTC

If I right click on my Powerbuilder Workspace, and select properties, the Properties window doesn't open and I can't do anything in PowerBuilder.


Alt-TAB doesn't show the properties window is open so can't use the suggestion I found to bring the properties window back onto my screen.

I tried creating a brand new workspace with no source control or anything else and it does the same thing.


Please help!  


Accepted Answer
Andreas Mykonios Accepted Answer Pending Moderation
  1. Monday, 14 November 2022 13:09 PM UTC
  2. PowerBuilder
  3. # Permalink


I guess that for some reason it open outside your monitor visible range. Try to press escape to see if it unfreezes. If yes I may be right in my first assumption (did you had a second monitor?).

By the way alt, left arrow, down arrow and enter (sequentialy) should enable window moving but if you don't know the real position it may be hard to relocate it.


  1. Tanya Weaver
  2. Tuesday, 15 November 2022 06:18 AM UTC
Thanks Andreas. The "esc" worked. however, the alt left arrow combination didn't, but I managed to use "ALT SPACE", then a pop up with "Move" came up on the right hand side of my screen (which gave me a clue as to where it had disappeared to) and after a LOT of left arrows, I got my properties box.

Thanks for the help, I really appreciate it.
  1. Helpful 2
There are no comments made yet.
Vladimir Uzlaner Accepted Answer Pending Moderation
  1. Friday, 26 April 2024 12:50 PM UTC
  2. PowerBuilder
  3. # 1

Thanks everyone for the hints. But for myself helped only temporary switching displays on the 'Rearrange your display' settings.

It looks like I started see this problem when I added new monitor.


There are no comments made yet.
Fedir Fedotov Accepted Answer Pending Moderation
  1. Thursday, 4 April 2024 09:23 AM UTC
  2. PowerBuilder
  3. # 2

whole IDE application disappeared somewhere outside visible monitor space.. restarting IDE did not helped, opening any project would not display main window... Cleared registry Computer\HKEY_CURRENT_USER\SOFTWARE\Sybase\PowerBuilder\22.0\Settings\WorkspacePropLastPosition , but only Ctrl+Space and Move helped to get the window back on screen..

There are no comments made yet.
Mark Goldsmith Accepted Answer Pending Moderation
  1. Monday, 14 November 2022 20:22 PM UTC
  2. PowerBuilder
  3. # 3

Hi Tanya,

Further to Andreas's reply you may wish to check and see what the current coordinates are of the Workspace properties dialogue and see if there are any large negative numbers.

This particular setting is not stored in the PB.INI but in the Registry. It's located at (assuming you're using PB 2019): Computer\HKEY_CURRENT_USER\SOFTWARE\Sybase\PowerBuilder\19.0\Settings The Value Name is WorkspacePropLastPosition and my current values, for example, are 192,492,1655,1860.

If your numbers look way off you could try the above numbers to see if it comes back into view.



There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.