1. Kwadwo Boahene
  2. PowerBuilder
  3. Wednesday, 9 May 2018 15:11 PM


          How do i connect to DB2 using SSL in Powerbuilder 2017 (1769)? Currently I connect to DB2 using this connection string ==>SQLCA.DBParm = "Connectstring='DSN=xxxxx;UID=yyyyy;PWD="+ls_pwd+"'"+",CommitOnDisconnect='No',Date=' \''yyyy-mm-dd\'' ',DateTime=' \''yyyy-mm-dd-hh.mm.ss.ffffff\'' ',Time=' \''hh:mm:ss\'' ',PacketSize=38000,Async=1"


the xxxx is the databasename and UID is the userid and ls_pwd is the password. This has been working from PB6 through 17 and now I am being told to connect using SSL - change of company policy. How is done?



Miguel Leeuwe Accepted Answer Pending Moderation
  1. Friday, 11 May 2018 10:27 AM
  2. PowerBuilder
  3. # 1

I might be wrong, but I don't think it will be possible to specify ssl attributes in an ODBC connection.

You can download a PB 12.5 dbparm connection guide here: http://infocenter.sybase.com/help/topic/com.sybase.infocenter.dc33820.1250/pdf/dbparm.pdf   It's old, but might help you on the right path. If anyone knows of a more recent version that info would be welcome.

Take a look at connecting to DB2 using JDBC or "native driver" (if powerbulder supports that one, the native driver would be best).

(we use a Tibero database, which is not supported by Appeon and cannot use SSL in an ODBC connection. We have to use JDBC in which we specify protocol=TCPS instead of the default protocol=TCP. It works great (once you've figured out the connection string).

An example of our Tibero dbparm connection string: 



the "(address= .... " is normally only necessary for specifying a list of clustered hosts. We don't have a clustered database, but we still had to use it to be able to specify the "protocol" parameter.




There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 9 May 2018 15:28 PM
  2. PowerBuilder
  3. # 2

Hi Kiwado;

     SSL support is all part of the ODBC realm and not PB`s.

The SSL setup is outlined by this MSDN post.


Regards ... Chris

There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.