1. Igor Perisic
  2. PowerBuilder
  3. Tuesday, 18 July 2023 20:26 PM UTC


I am able to use Git but I ran into a few obstacles I had to remove in order to get it working, I'm hoping to see if there is a better way to get Git working without removing these obstacles. 

To start, I am using GitLab that our company setup on our local server. Because of this, I think there are some certificate issues because it seems like its self-certified (could be wrong). Anyways, there are two ways I can use git. First is through git commands inside CMD with either SSH or HTTPS. The second is through PowerBuilders built in Source Control System - which I believe uses HTTPS. 

Cloning projects through git commands and CMD using SSH doesn't cause any problems - that works smoothly for me once I set up the public key. HTTPS caused some issues - nothing to do with PowerBuilder but with the certificate issue I mentioned earlier. To work around this, I had to run this command 

git config --global http.sslVerify false

and I believe this is used to verify ssl certificates. When turned off it doesn't need to verify the certificate but it could lead to some security issues. However, when i ran the reverse of that command

git config --global http.sslVerify true

I stopped having issues. It seems that turning it off and then back on fixes git stuff when using CMD - makes no sense to me how this fixed the problem but maybe sslVerify is still set to false even though I am setting it back to true... Unfortunately though, when attempting to use PowerBuilder's built in Git Source control i ran into more issues. If I set sslVerify to false in cmd - I can connect to the repository. If I set sslVerify to true I get an error "unknown certificate check failure".

That being said, there is definitely an issue with the certificate I am getting from GitLab, and this isn't something I can update on my own. If anyone is familiar with Git do you know of any workarounds around this that doesn't involve me compromising the security like setting sslVerify to false. Does PowerBuilder Source control allow for ssh ('git@localAddres:projects/windows/pb/projectName.git') instead of https (https://localAddres:projects/windows/pb/projectName). 

Edit: The main reason why I want to use PB's Git Source Control is to generate the ws_objects folder with the individual files. not sure if this is possible through CMD too or if its only a feature of PB's Source Control. 

Benjamin Gaesslein Accepted Answer Pending Moderation
  1. Wednesday, 19 July 2023 08:59 AM UTC
  2. PowerBuilder
  3. # 1

Hi Igor,

you can download the self-signed certificate from gitlab and install it on your local machine, which should get rid of the warning when connecting to gitlab via https. The arguably easiest way to do so is this:

  1. Use Chrome to browse to your gitlab repo
  2. Click the lock icon in the address bar
  3. Click "Connection is secure"
  4. Click "Certificate is valid", this should open a certificate viewer window
  5. go too the "Details" tab
  6. Click the "Export" button

This will allow you to download the certificate as a *.crt file. You can install these via rightclick in Windows Explorer.

(This might be possible in other browsers, too. Or you can download the cert using ssl on the command line. If you would prefer this, you should be able to find something on google.)

  1. Benjamin Gaesslein
  2. Thursday, 20 July 2023 09:35 AM UTC
PS: adding the certificate to Windows' certificate store does not seem to be enough.

But setting the http.sslCAInfo config for the current repository does the trick. Download the certificate as described but save it in .pem format to an accessible folder. Then execute this git command on a terminal app while you're in the folder of your repository:

git config http.sslCAInfo c:/path/to/yourcert.pem

Note that it's best to use forward slashes here. This keeps verification on and adds the certificate for one repository only.
  1. Helpful
There are no comments made yet.
kitty he @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 19 July 2023 08:04 AM UTC
  2. PowerBuilder
  3. # 2

Hi Igor,


If you have used Git in PB, there will be a .gitconfig file in your user profile folder (C:\Users\<username>\).

Please change sslVerify = true to sslVerify = false in this file and see if it resolves the issue with using PB.




  1. Benjamin Gaesslein
  2. Wednesday, 19 July 2023 08:52 AM UTC
That's the same thing the git config command does, just without the --global flag.
  1. Helpful
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.