1. Scottie Eades
  2. PowerBuilder
  3. Friday, 30 November 2018

Infomaker PSR report is requiring double quotes around all table names and field names.

Interactive SQL window does not require it.

only when creating a PSR report.

EX.

select "component"."cmpnt_id", "component"."cmpnt_name" from "component" where "cmpnt_id"  = 2134;

 

 

 

Infomaker 2017 Release 3 build 1858

Oracle 11

win 7 Pro

 

 

thanks,

 Scottie

Scottie Eades Accepted Answer Pending Moderation
0
Votes
Undo

Chris,

I think I have some other issues, that I will need to work out before pursuing the answer.

I"m getting a executable creation failure.

 

I've checked that my default library is the tutorial.

 

I'm a Smartplant Instrumentation Administrator (16+ years) not really a true dba...

mostly MSSQL in the last few years, so a little rusty on Oracle.

 

I am connected to a smartplant database (older version) that actually asks for infomaker 11.2 which no longer has a license generator and no longer support by Sybase, or SAP.

that's why I was trying to use Appeon.

I don't want to waste your time, so I will try to make sure everything is version compatible and configure correctly.

then try your solution.

 

I appreciate your time :)

thanks,

 Scottie

 

Comment
There are no comments made yet.
  1. Tuesday, 4 December 2018
  2. PowerBuilder
  3. # 1
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Scottie;

   To build an EXE in IM ...

1) Open the Library Painter

2) Select the from the "Design" menu - "Create Executable" 

3) Give the App a Title and EXE name ...

4) Pick at least one report or form ..

5) At the end of the wizard - select Finish.

6) Go to the EXE output Folder and look for its INI file

7) Open the INI in Notepad and check for the quote setting ..

HTH

Regards ... Chris

 

Comment
There are no comments made yet.
  1. Tuesday, 4 December 2018
  2. PowerBuilder
  3. # 2
Scottie Eades Accepted Answer Pending Moderation
0
Votes
Undo

Chris,

hi... thanks for the response.

assuming you are talking about the screen below.

I know what you mean.. the SQL has nothing to do with the report.

but strangely, when I type in the interactive SQL window or use another program...

the double quotes are not required and the SQL runs correctly.

it's only when I am using infomaker to build an SQL select report using syntax mode and hit return to finish the report format, etc.

I've been on MSSQL the last few years but before that... I was admin for oracle databases. I didn't remember having to do that before, but I've slept since then.

I have checked and unchecked the box for quotes in the screenshot below... to no avail. It seems to be something specific to the report formatting as you said, but no change checked or unchecked.

 

thanks,

 Scottie

 

 

 

Comment
Hi Scottie;



Just to check that IM is using the correct setting for the Table and Name quotes as per you DB Profile Painter setting .. can you build an EXE and see if the INI file built in the same folder as the EXE contains " DelimitIdentifier='No' " in the DBParm keyword assignment?



Regards ... Chris
  1. Chris Pollach
  2. Monday, 3 December 2018
Chris,

thanks for the suggestion... sorry I have never done that... is it part of infomaker or API or something?

:)

  1. Scottie Eades
  2. Tuesday, 4 December 2018
There are no comments made yet.
  1. Saturday, 1 December 2018
  2. PowerBuilder
  3. # 3
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Scottie;

  PSR's have nothing to do with SQL. They are basically the report format (basically, DataWindow source) plus it's data buffers. All in a propritary file format.

  In running any SQL to build an IM report, the SQL may or may not need quotes around DB indentiers. This is a requirement of the DBMS you are connected to and/or the DB client software used to connect to the DBMS (ie ODBC).

  You can control the addition & type of identifier character in the DB Profile Painter's "Quoted Indentier" settings.

HTH

Regards ... Chris

Comment
There are no comments made yet.
  1. Saturday, 1 December 2018
  2. PowerBuilder
  3. # 4
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.