1. John Greiner
  2. PowerBuilder
  3. Monday, 10 June 2019 17:43 PM UTC

Refresh is failing to add new Git object to .pbl. Object is present in ws_objects subfolder. Modified objects are imported without issue. Re-installed both Power Builder, build 1858 and Git V2.22 but issue remains. Need to know what could be causing error. Other users on their own platform do not experience this problem. Attached is error message on refresh failure. After failure, new object is not imported and the file in the ws_objects subfolder is locked, 'in use'.

Attachments (1)
Tom Jiang @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 11 June 2019 05:03 AM UTC
  2. PowerBuilder
  3. # 1

Hi John,

This happens when there is a conflict in some object that causes the IDE to fail to compile the object after importing the source code. You may press OK on this dialog and then do a full build to find out where the error is and then use Edit Source to resolve the conflict. 

BTW, the reason that others don't have this issue may be that they don't have local changes that would result in a conflict like yours. If your local changes are not important, a simple solution would be remove your local workspace folder and connect to the server to create the workspace again.


Tom Jiang

  1. Tom Jiang @Appeon
  2. Thursday, 13 June 2019 03:11 AM UTC
Hi John, when you say you associate does this, do you mean doing a fresh 'connect to workspace'? Another way you may try is to copy all the PBLs from your associate and replace the ones in your workspace.
  1. Helpful
  1. Aart Onkenhout
  2. Friday, 21 June 2019 13:29 PM UTC
Hi John, did you find a solution yet? I'm facing the same problem, tried uninstalling PowerBuilder, GIT, SourceTree and reinstall but to no succeed. Also tried 'connecting to workspace' and I'm sure there are no conflicts.
  1. Helpful
  1. Tom Jiang @Appeon
  2. Monday, 24 June 2019 09:58 AM UTC
Hi, the issue John had was mainly because he was using PowerBuilder IDE on Windows Server 2016, which is not supported. Please check the following link and make sure your are on the supported OS:

  1. Helpful
There are no comments made yet.
John Niespodzianski Accepted Answer Pending Moderation
  1. Friday, 22 November 2019 22:02 PM UTC
  2. PowerBuilder
  3. # 2

We are also experiencing this.  We have 6 developers working simultaneously, so we have a lot of feature branches and pull requests so our develop branch (where we "Refresh" from) is constantly changing.

Whenever we do a refresh (whether it's on the Workspace, Target, or individual PBL) we get the "One or more PB Objects failed to compile..." message.

We can click OK and it appears to refresh, but too often objects do not get updated.

The code base is solid - a full build before or after finishes cleanly.  So there isn't a conflict with anything code-related.  

The object referenced as the offender is always the 1st object in the PBL (if refreshing the workspace or target, the 1st object in the 1st PBL - usually a datawindow in our instance, which further supports it's not a code issue).

Please see my attachment - the example is the 1st datawindow in the refreshed PBL.

Has anyone else seen this behavior, and if so - come up with a solution?

I can open a formal bug report if requested.



Attachments (1)
There are no comments made yet.
Noel Hibbard Accepted Answer Pending Moderation
  1. Wednesday, 9 September 2020 17:18 PM UTC
  2. PowerBuilder
  3. # 3

I was running into this exact problem but only on my own machine. Other devs working on the same repo were not running into this problem. Turns out it was an issue with line endings. By default git has autocrlf enabled so when fetching files it converts all files to CRLF. I recently changed my git config to disable autocrlf which caused me to have a mix of line endings in the ws_objects folder and any objects that had LF endings would fail.

My fix was to scrap my local repo and then clone from scratch like this:

git clone <URL> --config core.autocrlf=true

This allows me to leave autocrlf disabled globally but have it enabled locally for any PowerBuilder related projects.

There are no comments made yet.
Armeen Mazda @Appeon Accepted Answer Pending Moderation
  1. Friday, 18 September 2020 15:17 PM UTC
  2. PowerBuilder
  3. # 4

The solution Noel mentioned about setting autocrlf=true is now implemented as a feature of PowerBuilder 2019 R3.  Beta is currently available and final release is most likely early December 2020.

There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.