1. John Greiner
  2. PowerBuilder
  3. Monday, 10 June 2019

Refresh is failing to add new Git object to .pbl. Object is present in ws_objects subfolder. Modified objects are imported without issue. Re-installed both Power Builder, build 1858 and Git V2.22 but issue remains. Need to know what could be causing error. Other users on their own platform do not experience this problem. Attached is error message on refresh failure. After failure, new object is not imported and the file in the ws_objects subfolder is locked, 'in use'.

Attachments (1)
Tom Jiang Accepted Answer Pending Moderation
0
Votes
Undo

Hi John,

This happens when there is a conflict in some object that causes the IDE to fail to compile the object after importing the source code. You may press OK on this dialog and then do a full build to find out where the error is and then use Edit Source to resolve the conflict. 

BTW, the reason that others don't have this issue may be that they don't have local changes that would result in a conflict like yours. If your local changes are not important, a simple solution would be remove your local workspace folder and connect to the server to create the workspace again.

Regards,

Tom Jiang

Comment
Hi John, when you say you associate does this, do you mean doing a fresh 'connect to workspace'? Another way you may try is to copy all the PBLs from your associate and replace the ones in your workspace.
  1. Tom Jiang
  2. Thursday, 13 June 2019
Hi John, did you find a solution yet? I'm facing the same problem, tried uninstalling PowerBuilder, GIT, SourceTree and reinstall but to no succeed. Also tried 'connecting to workspace' and I'm sure there are no conflicts.
  1. Aart Onkenhout
  2. Friday, 21 June 2019
Hi, the issue John had was mainly because he was using PowerBuilder IDE on Windows Server 2016, which is not supported. Please check the following link and make sure your are on the supported OS:

https://www.appeon.com/support/documents/appeon_online_help/pb2017r3/installation_guide_for_pb/ch03s02.html
  1. Tom Jiang
  2. Monday, 24 June 2019
There are no comments made yet.
  1. Tuesday, 11 June 2019
  2. PowerBuilder
  3. # 1
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.