1. Saroj Mungtaweepongsa
  2. PowerBuilder
  3. Thursday, 06 July 2017

In PowerBuilder 2017 IDE Database profile, I can normally connect on cloud remote database using MS SQL Server Native connection.

 

But, not in PowerServer & AEM.

 

Appeon Support Team Accepted Answer Pending Moderation
0
Votes
Undo

Hi,

 

If there are mutiple SQL Server instances on server machine? please check the the correct port is 1433. please refer to article below to solve this issue.

https://support.appeon.com/index.php?/Knowledgebase/Article/View/48/11/cannot-connect-to-the-sql-server

 

Regards,

ZhaoKai

Comment
HI ZhaoKai



 



I can solve this issue by follow your answer.



 



Thank you so much



Saroj

  1. Saroj Mungtaweepongsa
  2. Friday, 7 July 2017
Hi,



Glad to hear that. you aer welcome!.



Regards,

ZhaoKai

  1. Appeon Support Team
  2. Friday, 7 July 2017
There are no comments made yet.
  1. Friday, 7 July 2017
  2. PowerBuilder
  3. # 1
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Sarji;

  Did you turn on TCP/IP processing on in SS Express. Normally, this protocol  is off upon the initial SS Express installation. Both PowerBuilder IDE and the PowerServer needs to have this protocol active in SSX when you create a DB Profile in PB or a DataSource Connection profile is PS.

HTH

Regards ... Chris

Comment
Already turn on everything. And also temporary turn off firewall.















 



Inform you again, I can connect from PowerBuilder IDE. But not PowerServer .

  1. Saroj Mungtaweepongsa
  2. Thursday, 6 July 2017
Hi Saroj;



      Oh yes, PowerServer is 64 bit - so make sure that you have both the 32bit & 64bit SNC clients are installed from SSX.



Could that be it?



Chris

  1. Chris Pollach
  2. Thursday, 6 July 2017
There are no comments made yet.
  1. Thursday, 6 July 2017
  2. PowerBuilder
  3. # 2
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.