1. James Pitts
  2. InfoMaker
  3. Tuesday, 29 August 2017

We just converted our databases to MS SQL 2014.   I've been using Infomaker as a database tool for over 15 years.  When I open a table, the insert, delete, and update buttons are all highlighted and work as I'm used to.   If I do a search first, none of those options are available (grayed out).  I'm dbo on the databases.   Is this an Infomaker setting I'm missing or just something I can no longer do using MS SQL?

James Pitts Accepted Answer Pending Moderation
0
Votes
Undo

RESOLVED -  "dbo."  was appended to the table names (ie., customer vs dbo.customer).   While existing queries returned data, the insert row function didn't work.   Thank you for your help.

Comment
There are no comments made yet.
  1. Wednesday, 30 August 2017
  2. InfoMaker
  3. # 1
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi James;

 

     What version of are you using of IM and on what O/S?

 

  FYI:   I just created a new Form in IM 2017 and then added a few command buttons for filtering control. When I run the new form against my SS 2016 (using the SS native client) ... everything works perfectly whether a filter is active or not. No CB's in the menu or CB's I added to the form disable inappropriately.

 

IM 2017 Form:

Filter:

DB Profile:

 

SS DBMS:

 

Regards ... Chris

Comment
At the moment I'm using an Appeon trial version, Version 2017 Build 1666, on a Windows 10 workstation.  I should have the licensed version tomorrow.

  1. James Pitts
  2. Tuesday, 29 August 2017
I'm also using the ISQL Session to query and update the database.  

  1. James Pitts
  2. Tuesday, 29 August 2017
What version of Native Client file are you running?   I currently have sqlnccli11.dll (MSSS 14).   Can you try doing a select query on a table from the ISQL Session tab and let me know if the insert row button from the menu bar works?   I'm thinking it may be a database setting and not Infomaker.

  1. James Pitts
  2. Wednesday, 30 August 2017
There are no comments made yet.
  1. Tuesday, 29 August 2017
  2. InfoMaker
  3. # 2
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.