1. Gerrat Rickert
  2. PowerBuilder
  3. Friday, 20 October 2023 12:24 PM UTC

I can't get PowerBuilder to successfully check out a git project (this did work at one time - not sure what's changed).

This works fine for every other developer that tries, so there's something misconfigured on my machine specifically, but I'm not sure what.  

I've upgraded to the latest version, 2022 R2 Build 2819 (things didn't work on my machine with the last version either, so the upgrade didn't help).

When I startup PowerBuilder:

- I connect to a workspace, 

- fill out the form with the git project and my credentials,

- create a new checkout directory

- successfully connect to the git repo

- leave the "Regenerate all PBLs with the source code after download checked" (tried with this checked and unchecked - fails both ways).


When I click Ok, it connects to the repo, downloads all the files, spits out tons of lines like:

"PBL regeneration - Importing <xxx>"

Then at the end, the last log line says:
"Opening Workspace..."

and then a popup appears: "Targets - Not Opened"

"The following targets could not be opened and will be removed from the workspace"
and it lists all the .pbt files in the workspace
When I click "Ok", there is nothing left in the workspace.
If I try to manually add a target, it says "Could not add target because the target "c:\<whatever target>.pbt" could not be created.


Any suggestions to get this to work?

Andreas Mykonios Accepted Answer Pending Moderation
  1. Friday, 20 October 2023 12:41 PM UTC
  2. PowerBuilder
  3. # 1


What folder have you selected to store your project? It sees that for some reason it tries to write c:\ but this is not allowed by windows!


  1. Gerrat Rickert
  2. Friday, 20 October 2023 12:44 PM UTC
Tried many folders (not c:\directly).

It checks out all the files fine - they're all there.
  1. Helpful
There are no comments made yet.
Gerrat Rickert Accepted Answer Pending Moderation
  1. Friday, 20 October 2023 12:56 PM UTC
  2. PowerBuilder
  3. # 2

I think I found my issue.

I had git's `core.autocrlf=input` (needs to be `core.autocrlf=auto`) set for another project (not PowerBuilder).

I had probably checked out this project before I made that changed (a year ago), and everything was fine until I checked out the project fresh.


This seems like an easy thing for PowerBuilder to give a more informative error message on.


There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.