1. Daryl Foster
  2. SnapObjects
  3. Thursday, 29 August 2019 07:43 AM UTC


I've started using SnapDevelop today for the first time and I've got a small issue when I run my project. It pops up with the attached Security Warning about installing a root certificate for localhost.  I only seem to get this message if I run from the SnapDevelop IDE.  I don't get it when I use "dotnet run" from a command prompt.  It all works fine when I click No, but it's annoying.  Does anyone have any idea how to prevent it?

Attachments (1)
Accepted Answer
Logan Liu @Appeon Accepted Answer Pending Moderation
  1. Friday, 30 August 2019 07:31 AM UTC
  2. SnapObjects
  3. # Permalink

Hi Daryl,

When starting an ASP.NET Core project, It's recommened to trust the HTTPS development certificate. Refer to ASP.NET document:



You can also manage HTTPS development certificates by dotnet dev-certs command line.

Usage: dotnet dev-certs https [options]

-ep|--export-path Full path to the exported certificate
-p|--password Password to use when exporting the certificate with the private key into a pfx file
-c|--check Check for the existence of the certificate but do not perform any action
--clean Cleans all HTTPS development certificates from the machine.
-t|--trust Trust the certificate on the current platform
-v|--verbose Display more debug information.
-q|--quiet Display warnings and errors only.
-h|--help Show help information

When you don't want to trust trust the HTTPS development certificate, there should be an option in this dialog to prevent this message from showing again. You can report a SnapDevelop enhancement requestment in the Appeon Standard Support at https://www.appeon.com/standardsupport/.


  1. Daryl Foster
  2. Monday, 2 September 2019 01:51 AM UTC
Thanks Logan, I appreciate that. It fixed my problem.
  1. Helpful
There are no comments made yet.

There are replies in this question but you are not allowed to view the replies from this question.