1. Chris Victor
  2. PowerBuilder
  3. Thursday, 5 March 2020 14:40 PM UTC

We converted our pb12.5 app to PB2019 build 2170 in November 2019. We use subversion for source control. Everything was working great, including svn commits, until my network logon password expired and i had to change it a couple of weeks ago. Since then, i get the subject error when i attempt to commit any object that i've been working on. I tried going into the Source Control tab on the workspace properties and updating the password in there but the error still occurs. Is there something else I should be doing regarding svn and pb2019 when my network password changes?

Tom Jiang @Appeon Accepted Answer Pending Moderation
  1. Friday, 6 March 2020 08:13 AM UTC
  2. PowerBuilder
  3. # 1
Hi Chris,

Do you use PowerBuilder native interface for SVN? If that's the case the encrypted credential should be saved in "%APPDATA%/Subversion/auth/svn.simple." You may try to clean all the files in this folder and then change your password again in PB IDE and see if it works (backup the files before you clean it just in case).
If it still doesn't work, you may try setting your password using TortoiseSVN and see if it resolves the issue.
Tom Jiang
  1. Chris Pollach @Appeon
  2. Friday, 6 March 2020 16:35 PM UTC
Hi Chris ... FYI: The "PushOK" product uses the SCCAPI protocol and *not* native SVN.
  1. Helpful
  1. Chris Victor
  2. Friday, 6 March 2020 19:01 PM UTC
So, you're saying native svn is not able to detect a password change?
  1. Helpful
  1. Chris Pollach @Appeon
  2. Friday, 6 March 2020 19:55 PM UTC
Hi Chris ... no, not at this time. We had a similar ticket in the support system a few months back with a similar issue around an active directory policy change. The PB developers had to basically do what you did to reconnect to SVN. However because of that ticket, Engineering is now looking at this SVN user/pwd/policy lockout issue closer.

  1. Helpful
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.