1. Konstantin Goldobin
  2. PowerBuilder
  3. Tuesday, 17 December 2019 10:14 AM UTC


I'm trying to have a look at the native Subversion interface in PB2017 R3, and this is what I've done:

1. I added my workspace to an SVN repository using the "Add to Source Control" pop-up menu in PB.

2. I closed the workspace in PB.

3. I clicked "Connect to Workspace" in the pop-up menu for "No Workspace" (the opened dialogue pre-loaded all values like Repository URL etc).

4. I entered a different folder name into "Checkout Directory" to test getting the workspace from SVN and clicked "OK".

This resulted in getting the following error message:

Title: Source Control

Text: Failed to find the workspace in the specified repository!

A colleague of mine tried to do the same on his computer and got the same error. Checking out the uploaded workspace using TortoiseSVN works with no issues. Does anybody know what the problem might be?

Michael Kramer Accepted Answer Pending Moderation
  1. Tuesday, 17 December 2019 12:13 PM UTC
  2. PowerBuilder
  3. # 1

Hi Konstantin, 

Using new native source control for Git, I found that the PBW workspace file has to reside in the source control root folder. 

Any file outside that root folder's domain is ignored by native source control. 

You may find similar behavior for SVN.

  1. Konstantin Goldobin
  2. Tuesday, 17 December 2019 13:07 PM UTC
Hi Michael,

It is located in the root of the folder that "Add to Source Control" created. The name of that folder was derived from the name of the workspace, and I did not see any way of changing either the name of the folder or the location of the workspace file.

Meantime, I tried to do the same using a local SVN repository and a test workspace, and this is what I got upon Adding to Source Control:

---------- Source Control

Adding to source control

Starting to find files...

Finding file: C:\_pb17_workspaces\test_native_subversion_interface.

Finding file: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface.pbw.

Finding file: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface_app.

Finding file: C:\_pb17_workspaces\test_native_subversion_interface\ws_objects\test_native_subversion_interface_app\test_native_subversion_interface_app.pbl.src.

Finding file: C:\_pb17_workspaces\test_native_subversion_interface\ws_objects\test_native_subversion_interface_app\test_native_subversion_interface_app.pbl.src\test_native_subversion_interface_app.sra.

Finding file: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface_app\test_native_subversion_interface_app.pbl.

Finding file: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface_app\test_native_subversion_interface_app.pbt.

Completed in finding files.

Preparing to add to source control...

User information confirmed.

SVN client is uploading files. Please wait...

Adding file: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface.pbw.

Adding directory: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface_app.

Adding file: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface_app\test_native_subversion_interface_app.pbl.

Adding file: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface_app\test_native_subversion_interface_app.pbt.

Adding directory: C:\_pb17_workspaces\test_native_subversion_interface\ws_objects.

Adding directory: C:\_pb17_workspaces\test_native_subversion_interface\ws_objects\test_native_subversion_interface_app.

Adding directory: C:\_pb17_workspaces\test_native_subversion_interface\ws_objects\test_native_subversion_interface_app\test_native_subversion_interface_app.pbl.src.

Adding file: C:\_pb17_workspaces\test_native_subversion_interface\ws_objects\test_native_subversion_interface_app\test_native_subversion_interface_app.pbl.src\test_native_subversion_interface_app.sra.

Committing the added file: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface.pbw.

Committing the added directory: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface_app.

Committing the added file: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface_app\test_native_subversion_interface_app.pbl.

Committing the added file: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface_app\test_native_subversion_interface_app.pbt.

Committing the added directory: C:\_pb17_workspaces\test_native_subversion_interface\ws_objects.

Committing the added directory: C:\_pb17_workspaces\test_native_subversion_interface\ws_objects\test_native_subversion_interface_app.

Committing the added directory: C:\_pb17_workspaces\test_native_subversion_interface\ws_objects\test_native_subversion_interface_app\test_native_subversion_interface_app.pbl.src.

Committing the added file: C:\_pb17_workspaces\test_native_subversion_interface\ws_objects\test_native_subversion_interface_app\test_native_subversion_interface_app.pbl.src\test_native_subversion_interface_app.sra.

Sending content: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface.pbw.

Sending content: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface_app\test_native_subversion_interface_app.pbt.

Sending content: C:\_pb17_workspaces\test_native_subversion_interface\test_native_subversion_interface_app\test_native_subversion_interface_app.pbl.

Sending content: C:\_pb17_workspaces\test_native_subversion_interface\ws_objects\test_native_subversion_interface_app\test_native_subversion_interface_app.pbl.src\test_native_subversion_interface_app.sra.

Finalizing commit.

Failed to execute process.

  1. Helpful
  1. Konstantin Goldobin
  2. Wednesday, 18 December 2019 09:19 AM UTC
Hello Michael! I included screenshots in my other reply where you can see the repository structure.
  1. Helpful
There are no comments made yet.
Konstantin Goldobin Accepted Answer Pending Moderation
  1. Tuesday, 17 December 2019 13:40 PM UTC
  2. PowerBuilder
  3. # 2

OK, Adding to Source Control of my test workspace worked from the second attempt, and I was even able to download the workspace into another folder. So, I went ahead and tried to reconstruct the structure of the real repository in my local one, and Added to Source Control again. After that I'm getting the same error message when trying to Connect to Workspace to a different checkout folder. This is the repository structure:

And the error:

  1. Michael Kramer
  2. Wednesday, 18 December 2019 11:19 AM UTC
Hi Konstantin, sorry for late reply. 4 days left of current contract so I'm quite busy finishing my final sprint. I would need to try out similar SVN check-in/check-out to figure out what the workaround/fix is. And I simply don't have the time before New Year. I hope someone else with practical experience on Native Source Control for SVN can join and help out before I can commit to this. Sorry / Michael
  1. Helpful
There are no comments made yet.
Tom Jiang @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 17 December 2019 14:04 PM UTC
  2. PowerBuilder
  3. # 3

If your repository link is, https://localhost/repo and your workspace name is ws, after you add to source control, PB will create this ws folder in repo and the other developers will need to use the link https://localhost/repo/ws to connect to workspace from their side. 

  1. Konstantin Goldobin
  2. Wednesday, 18 December 2019 09:18 AM UTC
Thanks! I believe this is exactly what I am doing. I updated the screenshot in my other reply so that the folder name was shown in Repository URL.
  1. Helpful
There are no comments made yet.
Konstantin Goldobin Accepted Answer Pending Moderation
  1. Monday, 12 April 2021 14:42 PM UTC
  2. PowerBuilder
  3. # 4


Hoping that things got better with the native SVN interface in 2019R3, I tried to "Connect to workspace" using the same repository structure and got the same error. Is there a restriction on the repository path length?

Best regards,

  1. Tom Jiang @Appeon
  2. Tuesday, 13 April 2021 06:47 AM UTC
Are your PB IDE installed on a Windows Server or Windows 10 machine? Please note PB IDE is not supported to run on a server machine (PB Runtime supports to run on a server machine). I think previous there was some issue using Source Control for some customer on a Windows Server machine.

On the other hand, if you click on the Test Connection button, what error do you get? Do you have any proxy on your network between you and your SVN server?

If you create a simple test case with the PBW, PBT and PBL in the same folder, are you able to reproduce the issue?

BTW, have your upgraded to 2019 R3?


Tom Jiang

  1. Helpful
There are no comments made yet.
Konstantin Goldobin Accepted Answer Pending Moderation
  1. Tuesday, 13 April 2021 08:49 AM UTC
  2. PowerBuilder
  3. # 5

OK, this is getting more confusing... I am using PB 2017 R3 1951 and PB 2019 R3 2670 on Windows 10. I created two test folders in my local repository: one is on the root level and the other is much deeper:

With the first one everything works in PB2017 and PB2019:

If I try to do the same with the second folder and click Test connection, I get the error:

If I remove the workspace folder name from the path and click Test connection, it succeeds:

However, when I click OK, it fails anyway:

In PB2019 it seems working:

Could you please confirm that it was fixed in 2019?


  1. Tom Jiang @Appeon
  2. Thursday, 15 April 2021 02:28 AM UTC
I double checked with the development and you are right that they increased the length for the URL in a later version. Sorry for not being able to help with your issue earlier! Please mark your issue as resolved if this answers your question. Thanks!
  1. Helpful
  1. Konstantin Goldobin
  2. Thursday, 15 April 2021 11:18 AM UTC
Thank you, Tom! Could you please find out what the maximum length is?
  1. Helpful
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.