1. Carlo Guglielmi
  2. PowerBuilder
  3. Monday, 14 June 2021 18:13 PM UTC

I select a field declared as nvarchar(nmax) from a table in sqlserver using an odbc connection (even with a native driver). The result from the select is truncated if the value in the column has more then 32676 character. I use Power Builder 2019R2. I'm able to write the right value using a datawindow, but I need to use a select instead a dw for read a single record.

Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Monday, 14 June 2021 18:32 PM UTC
  2. PowerBuilder
  3. # 1

Hi Carlo;

   The PB IDE install defaults to a 32K maximum data stream for BLOB and Long Textual data. For the native SS connection or connecting via ODBC you need to set the following in your PB App's DBParm connection settings in the Transaction Object, as follows ...

  • SQLCA.DBParm = "PBMaxBlobSize=nnnnnnn"  // Binary
  • SQLCA.DBParm = "PBMaxTextSize=nnnnnn"    // Text

Note1: Both settings can co-exit in the DBParm field of your transaction object.

Note2: You can effect the same in an ODBC connection by modifying the PBODB190.ini file and adding the above settings to that control file.

   Please check the above keywords in the PB Help file for more detailed information.


Regards ... Chris


There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.