1. Bjarne Anker
  2. PowerBuilder
  3. Friday, 10 May 2019

Hi.

 

One of our customers have almost only 4K monitors in their organization.

They run our PB 2017 R3 application via RDP and/or Remote Apps (Work Resources) in Windows 10.

They report that they're experiencing very sluggish performance in almost every window in our application.

One typical scenario is that the application hangs with an hourglass and "Not responding" when they just select an record in a datawindow browse. But if I log into the same RDP session with my ThinkPad T480S laptop, I don't have any issues at all.

One of the users also tried to copy the application to his local computer, and still experience some of these mysterious hang ups.

 

Does any of you have these same problems, and is there a way to avoid them?

I think it's related to videodriver issues, and not our application, since I never experience these issues when I'm running our application on their terminal servers.

 

Br,

 

Bjarne

Maritech Systems AS

1
Votes
Undo

Hi Bjarne

It does sound like an environmental issue, if it is only slow on machines with the 4K monitors then are they all the same monitors same OS and drivers. If so then perhaps getting the latest drivers from the manufacturer for the graphics might help.

I'm no expert, but does it matter what driver you have on the Terminal Server? Are these not driving the 4K screen properly, might need drivers installing on the Server too.

Just some random thoughts that might help.

Regards

David

 

Comment
There are no comments made yet.
  1. Friday, 10 May 2019
  2. PowerBuilder
  3. # 1
Kevin Ridley Accepted Answer Pending Moderation
0
Votes
Undo

Can you try plugging in a non 4k monitor with the correct drivers and see if there's still an issue?  At least that would help isolate the problem.

Comment
Hi.



It works just fine when I connect with my Thinkpad T480S laptop with standard 1920 resolution.

My customer tells me that they experience significant improvement in performance when using a non-4K display.

But they still need to resolve this, since everyone has these gigantic monitors.



Br,



Bjarne
  1. Bjarne Anker
  2. Saturday, 11 May 2019


Have you tried contacting the company your client bought the monitors from and/or the manufacturer to see if there is an updated driver for better performance?
  1. Kevin Ridley
  2. Monday, 13 May 2019
There are no comments made yet.
  1. Friday, 10 May 2019
  2. PowerBuilder
  3. # 2
Roland Smith Accepted Answer Pending Moderation
0
Votes
Undo

Not sure if this helps but we have noticed that WebEx can slow down the PowerBuilder IDE and app.

Try running a lower resolution.

Comment
Hi.



I've been thinking the exact same thing.

In fact, it kinda makes sense since I never experience any issues with my laptop, even if I connect to their RDP via VPN outside the organization.

They have Gigabit networking across the entire network, so that's no issue.



I will relay the idea to my customer and make them test with 1920 resolution.



The biggest issue is that they use Microsoft Remote Apps, and I'm not sure if you can specify resolution when running applications in that mode.

But a test with direct connection to the RDP desktop is for sure first step.



Thanks,



Bjarne
  1. Bjarne Anker
  2. Saturday, 11 May 2019
There are no comments made yet.
  1. Friday, 10 May 2019
  2. PowerBuilder
  3. # 3
Bjarne Anker Accepted Answer Pending Moderation
0
Votes
Undo

Hi.

 

So I just added some simple logging to one of the forms.

I use this code at the very beginning in datawindow.rowfocuschanging():

il_start = CPU()

And then I use this code at the very end of datawindow.rowfocuschanged() to calculate the duration:

il_used = CPU() - il_start

 

In average, this operation takes 55 ms on my computer, running the application locally on Windows 10 with a local database (SA16).

The selected row changes immediately.

 

In my customers application, the operation takes 82 ms in average according to my log.

However, the users says that it sometimes takes as much as 35 seconds before the selected row is changed.

In the meanwhile, the application hangs with "(Not responding)" in the titlebar.

 

They are running the application in Microsoft Remote Apps on 4K displays.

When running the application locally on one of the computer, it still takes over 10 seconds before the row changes.

This tells me that the problem is in the drawing/graphics (perhaps OS related?) and not in our application.

The only real difference between my setup and the customers environment is the 4K monitors.

 

So I've ordered a 32" 4K monitor now solely for testing this at my desk.

 

Has anyone experienced this?

Anyone from Appeon that have a comment?

 

 

Regards,

 

Bjarne

Comment
There are no comments made yet.
  1. Wednesday, 19 June 2019
  2. PowerBuilder
  3. # 4
Michael Kramer Accepted Answer Pending Moderation
1
Votes
Undo

Hey Bjarne,

Just as puzzled as everyone else. At home I have a 4K monitor (Samsung) and a i5 Surface Laptop running Win10 Pro. Very up to date on all drivers, apps, and O/S. No performance issues at all.

To me, it really sounds like some drive/environment combo resulting in slow performance.

Good luck hunting. Hopefully you can return with resolution so we all can learn.

HTH /Michael

Comment
Thanks.



Will post back my findings when i get the 4K monitor up and running on my desk in a couple of hours.



Bjarne
  1. Bjarne Anker
  2. Thursday, 20 June 2019
There are no comments made yet.
  1. Wednesday, 19 June 2019
  2. PowerBuilder
  3. # 5
Roland Smith Accepted Answer Pending Moderation
1
Votes
Undo

On the RemoteApp shortcut you can set the color depth. Have them choose a lower value.

Comment
Hi.



Tried this, and it had no effect.
  1. Bjarne Anker
  2. Thursday, 20 June 2019
There are no comments made yet.
  1. Thursday, 20 June 2019
  2. PowerBuilder
  3. # 6
Miguel Leeuwe Accepted Answer Pending Moderation
0
Votes
Undo

Not a 100 % sure, but I think It's a windows 10 problem. A bug that should have fixed by long now.

I also mentioned the solution to this problem on: https://www.appeon.com/standardsupport/search/view?id=2791

There's a little tool that basically let's you get around the problem by using windows 8.1 DPI scaling instead of the one of windows 10: http://windows10-dpi-fix.xpexplorer.com

1) Set your "Windows Display" Scaling to 100% (if it's now for example 125%, very frequent on laptops)
2) Then run the program, check the lower radiobutton to use windows 8.1 dpi-scaling.
3) Reboot
Should be fixed.

See also:

https://www.groovypost.com/howto/fix-fuzzy-windows-10-fonts-high-resolution-displays/

 

HIH,

MiguelL

Comment
Thanks.



One of the users which are reporting this issue installed this tool, but it had no effect.



Bjarne
  1. Bjarne Anker
  2. Thursday, 20 June 2019
sorry to hear that. It resolved my problems with splashtop remote. Did he reboot the pc? What settings has he got in RDP's display settings? Try full-screen and like Roland said, a lower color depth. 24 bit shoud be enough.



regards,
  1. Miguel Leeuwe
  2. Thursday, 20 June 2019
There are no comments made yet.
  1. Thursday, 20 June 2019
  2. PowerBuilder
  3. # 7
Bjarne Anker Accepted Answer Pending Moderation
0
Votes
Undo

Hi.

 

I have no problem running the application on my brand new 4K monitor.

I run it locally and also the Remote Apps provided by our customer - no lag what so ever.

 

But I remember that we had some problems in PowerBuilder back in the days where the retrieval arguments for a datawindow was displayed empty and wrong due to a service i Windows.

"Touch" or something like this? Maybe that has some effect in this case?

Also, some of the users working there are using Microsoft Surface laptops.

I'm using a standard Lenovo ThinkPad.

 

Just throwing balls up in the air here :)

 

Regards,

 

Bjarne

Comment
There are no comments made yet.
  1. Thursday, 20 June 2019
  2. PowerBuilder
  3. # 8
Bjarne Anker Accepted Answer Pending Moderation
0
Votes
Undo

Hi.

 

Another update:

Tested this on two Lenovo Yoga X1 laptops with touch screens, and both have the same issue.

Our customer has just Microsoft Surface and X1 Yoga in the entire organization, all with touch screens.

So I think I've isolated the problem. Now it's all about resolving the issue...

 

I remember that there's a service which can be stopped?

That resolved the issue I had with the corrupt retrieval arguments list i PB IDE back in the days.

 

Regards,

 

Bjarne

Comment
Maybe this should be reported as a Bug?

regards
  1. Miguel Leeuwe
  2. Friday, 21 June 2019
Hi.



I have reported it, but Appeon will need a reproducible case to fix the issue.

And that proves to be a bit of a challenge.

I'm not entirely sure how I can provide this, but I'll try to make it happen in some way.

I have tried a local version of the application on a computer which experiences the issue when running the application from my customers MS Remote Apps site, and the lag is not very visible.

This is a different model laptop than my customer has, so I'm trying to replicate the problem at my local computer now.



Bjarne
  1. Bjarne Anker
  2. Friday, 21 June 2019
Hello,

Yes, I get it's going to be difficult. Maybe they have a surface pro at Appeon or maybe they can remote connect with you and see the problem.

Goodluck!
  1. Miguel Leeuwe
  2. Friday, 21 June 2019
There are no comments made yet.
  1. Thursday, 20 June 2019
  2. PowerBuilder
  3. # 9
Roland Smith Accepted Answer Pending Moderation
0
Votes
Undo

Do you have any details on the fix that you can share with us?

I am having a similar problem but 4K monitors are not the problem

The app works fine on developers laptops with PB/IM installed. Our QA group only has IM installed and the app is slow. Both groups use Dell laptops with Windows 10. It is also slow on Windows Server accessed via Remote Desktop.

 

Comment
Hi.



We have isolated the problem to touch-screens on Microsoft Surface and Lenovo Yoga laptops.

Appeon wants us to submit a reproducible case, but we are in no position to do that.

My customer is currently researching the matter, trying with new drivers and such. But still the same.

So the solution for now is to disable touch on the laptops. Which is not a great thing, since that's the main reason why you purchase a Surface or Yoga in the first place.



Hopefully this will be fixed in a driver from the manufacturers or in a MR from Appeon for PB 2019 sometime in the near future.



Bjarne
  1. Bjarne Anker
  2. Thursday, 4 July 2019
As I remember, Intel(R) Precise Touch Device (Device Manage > Human Interface Devices) is part of the touch&pen driver set despite not documented as such. So the way to get it updated correctly is to RMB > Uninstall device and then restart the device. Looking at MS docs for touch & pen issues on Surface Laptop you will find a few more device drivers that also need uninstall. After reboot, Win O/S identifies missing drivers and download required drivers in "relevant versions".

My issue wasn't performance but completely lost pen support and restricted touch to one-point touch. I'm now back at 10-point touch and full pen support.

HTH /Michael
  1. Michael Kramer
  2. Thursday, 4 July 2019
There are no comments made yet.
  1. Wednesday, 3 July 2019
  2. PowerBuilder
  3. # 10
Roland Smith Accepted Answer Pending Moderation
1
Votes
Undo

I've discovered that in PB 2019 if you are NOT using themes and do not include pbtheme190.dll in the runtime, the entire app will run extremely slowly.

It appears that even when theming is not in use, it is still attempting to load the pbtheme190.dll library into memory and the constant searching for the file is slowing it down.

Comment
There are no comments made yet.
  1. Monday, 8 July 2019
  2. PowerBuilder
  3. # 11
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.