1. Sivaprakash BKR
  2. PowerBuilder
  3. Wednesday, 13 December 2017 06:21 AM

Hello,

I have column(s) with dddw's to facilitate easy entry of master / lookup tables values.  Sometimes, it's annoying the users (particularly Grid / Tabular dw) that they accidently press arrow keys which changes the values unknowingly and when they save (after making changes which they intended to) the whole changes are saved back, including the one which was unknowingly modified.   

To solve this issue, I plan to modify those dddw columns to normal edit text field, where by pressing a particular key they can select those values from a response window.  This modification I plan to change at runtime, through scripts.   So that only those who wants this change can have it, by setting a parameter.

I tried googling, but not found a working a code.   Would like to know, whether this possible through code or not ?   Is yes, any code snippets available ?

Happiness Always
BKR Sivaprakash

 

Sivaprakash BKR Accepted Answer Pending Moderation
  1. Thursday, 14 December 2017 11:44 AM
  2. PowerBuilder
  3. # 1
0
Votes
Undo

No 'Displayonly' option available for columns having dropdown data windows.   Any other suggestions ?

Happiness Always
BKR Sivaprakash

 

Comment
You are right. The DisplayOnly option is not available for columns with DDDW edit style.



But If I understand you right you want to remove the DDDW edit style at runtime. The Modify statement make this change. It works for me.

  1. René Ullrich
  2. Friday, 15 December 2017 06:18 AM
There are no comments made yet.
René Ullrich Accepted Answer Pending Moderation
  1. Wednesday, 13 December 2017 07:12 AM
  2. PowerBuilder
  3. # 2
0
Votes
Undo

You may try this:

dw_1.Modify ("yourcolumn.edit.displayOnly='yes'")

Comment
Thanks Rene Ullrich



Looks like a very good suggestion.  I'll try out.

  1. Sivaprakash BKR
  2. Wednesday, 13 December 2017 07:55 AM
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.