1. Simone Olianti
  2. PowerServer
  3. Monday, 16 August 2021 11:18 AM UTC

Hello everyone, i've successfully built and deployed my pb2021 cloud app, then compiled the web api and everything worked fine on my local machine.
Later i've tried to publish the PS web api to a remote web server configured on a windows 2016 server machine using web deploy inside Snapdevelop2021 and it succeded without issues.
But when i try to run my app from the cloud app laucher, i'm getting this error: R0221 (Session creation failed)
What could be the reason of this issue?

tia,

simone

(Powerbuilder 2021 Build 1288 using my developer ps license)

Attachments (2)
Accepted Answer
Simone Olianti Accepted Answer Pending Moderation
  1. Monday, 16 August 2021 12:39 PM UTC
  2. PowerServer
  3. # Permalink

sorry, it was my fault and just a firewall issue on the web server machine. Working good now!

Comment
  1. Armeen Mazda @Appeon
  2. Monday, 16 August 2021 15:22 PM UTC
Glad to hear that!
  1. Helpful
There are no comments made yet.
Shu Wei Chen Accepted Answer Pending Moderation
  1. Monday, 23 August 2021 08:15 AM UTC
  2. PowerServer
  3. # 1

I also have the same problem R0221 (Session creation failed), but my firewall is turned off, what else can cause web API problems?

Attachments (1)
Comment
  1. Shu Wei Chen
  2. Monday, 23 August 2021 08:50 AM UTC
Thanks for your answer

1. Where can I check the web api port, is it in IIS?

2. Where can I check or set the'twice website authorization'?
  1. Helpful
  1. Simone Olianti
  2. Monday, 23 August 2021 09:21 AM UTC
hi Shu try have a look at this doc:

https://docs.appeon.com/snapdevelop2019r3/Publish/index.html

Probably there is one more recent but this helped me to do the trick
  1. Helpful
  1. Armeen Mazda @Appeon
  2. Monday, 23 August 2021 16:02 PM UTC
The default should be http://localhost:5000

When you compile and run the C# REST APIs, there will be a command prompt box opened and inside of that it shows the port #.
  1. Helpful
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.