1. Jon Stoller
  2. PowerBuilder
  3. Wednesday, 28 March 2018

In the PowerBuilder script editor - I stopped getting error messages when I make a mistake creating a script.

For example, suppose I make a typing mistake and spell the name of a variable incorrectly.  When I try to save I used to get a message stating there are errors and do I want to continue.  If I said I didn't want to continue the system used to give me a message to the effect that the variable didn't exist.  Also the cursor would go to the line where the error was and the line would be highlighted. 

Example: 

Below is an example of the code I enter.   
string     ls_textcolumn
ls_textxxxxx = "ABC123"

I try to SAVE. 

The system does not save the script. 
The cursor goes to the line where the error is, but it does not state that there is an error. 
There is no message explaining the error. 
The cursor goes to the line where the error is, but the line does not get highlighted.

What is going on?  Is there a switch or checkbox that controls the feature that gives me text error messages or not?  I was thinking that maybe I accidentally turned it off or "unchecked" it.  Did I erase something? 

If anybody knows anything about this please let me know.  I need to get messages telling me what my errors are.  Without them I feel like I am working blind. 

Jon Stoller

 

Ronnie Po Accepted Answer Pending Moderation
0
Votes
Undo

You might check to see if you've somehow resized the error message panel down to zero height. It normally sits right below the script panel.

Comment
There are no comments made yet.
  1. Wednesday, 28 March 2018
  2. PowerBuilder
  3. # 1
Miguel Leeuwe Accepted Answer Pending Moderation
0
Votes
Undo

Hi,

I've seen funny stuff also with the compiler. Most of them solved when doing a full uninstall and re-install. Sorry for not being able to offer more help.

Comment
There are no comments made yet.
  1. Wednesday, 28 March 2018
  2. PowerBuilder
  3. # 2
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.