1. Haihong Yang
  2. PowerBuilder
  3. Thursday, 15 September 2022 18:45 PM UTC


We are working on moving PowerBuilder code to Azure Devops and using pipeline to build application. We created PowerShell script to call pbc190.exe to compile. We have a resource folder to store all image files, including the icon file for exe. When we manually run the PowerShell script to build, the icon display on the exe file. But when we using pipeline to build, the icon does not display on exe file. We tried copy the icon file to the same folder that exe file produced, it does not work either. Does anybody know what is the issue? Why pipeline is different?



Haihong Yang   

Haihong Yang Accepted Answer Pending Moderation
  1. Tuesday, 20 September 2022 16:46 PM UTC
  2. PowerBuilder
  3. # 1


I tried. It does not working. Since this works when running locally, not working for pipeline, it must be an access issue. Do you have any other suggestion?




Haihong Yang

  1. Chris Pollach @Appeon
  2. Tuesday, 20 September 2022 20:14 PM UTC
Hi Haihong;

That should have worked.

If this is still an issue, please open a Support Ticket for this problem.

Regards ... Chris
  1. Helpful
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Friday, 16 September 2022 02:16 AM UTC
  2. PowerBuilder
  3. # 2

Hi Haihong ;

  Tip: Make sure that the ICO file for the App as defined in the Application Object does not include a path to the ICO file. Then also, the ICO file is located in the root folder of where your Application's WorkSpace is located.  HTH

Regards ... Chris

There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.