1. John Vanleeuwe
  2. PowerBuilder
  3. Wednesday, 11 April 2018

HI all,

 

From the download page i read

 

The release note for Build 1769 says:

Installing this revision requires you to uninstall the original version 2017 first. If you have already installed build #1756 of this revision, we will provide an MR for you to apply on top of the build in April.

 

 

Does this mean we can't have PB2017 build 1666 running on the same devpc as PB2017R2 in 2 different folders ?

Or are we forced to migrate our production code also to PB2017R2 just in order to start testing the restclient / httpclient functionality ?

 

TIA

John

 

 

 

Accepted Answer
René Ullrich Accepted Answer Pending Moderation
0
Votes
Undo

You can't have installed two releases of PB 2017 on the same machine because the DLL names are the same.

You may have a second release on a virtual machine.

Comment
You are exactly right Rene!

  1. Armeen Mazda
  2. Wednesday, 11 April 2018
There are no comments made yet.
  1. Wednesday, 11 April 2018
  2. PowerBuilder
  3. # Permalink
Roland Smith Accepted Answer Pending Moderation
0
Votes
Undo

I had the same issue with PB 11 and 11.2 and solved it. Try doing this:

Copy C:\Program Files (x86)\Appeon\PowerBuilder 17.0 to C:\Program Files (x86)\Appeon\PowerBuilder 17.0.GA

Copy all the .dll files from C:\Program Files (x86)\Appeon\Shared\PowerBuilder into C:\Program Files (x86)\Appeon\PowerBuilder 17.0.GA

Uninstall PB 2017

Install PB 2017.R2

Now you can run the GA version using pb170.exe located in  C:\Program Files (x86)\Appeon\PowerBuilder 17.0.GA.

 

Comment
Hi.



I am about to test PB2017.R2. Up to now we use PB12.6.



Is it at least possible to have PB2017.R2 installed parallel to PB12.6 and other former powerbuilder versions on the same machine?



Thanks.



Rolf

  1. Rolf Knaden
  2. Thursday, 12 April 2018
Yes, you can have different major versions of PB installed on the same machine.

  1. Brad Mettee
  2. Thursday, 12 April 2018
Hey folks,



I know this is a couple month old thread, but I have a related question.  We just purchased Appeon's version of PB.  Moving from an older version. Anyway, I'm wondering if I should just skip downloading the original PB 2017 and just start with R2 (build 1769, dated 03/26/2018)?



Thanks!

Jim



 

  1. Jim Means
  2. Friday, 1 June 2018
There are no comments made yet.
  1. Wednesday, 11 April 2018
  2. PowerBuilder
  3. # 1
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.