1. Yakov Werde
  2. PowerBuilder
  3. Tuesday, 18 January 2022 20:15 PM UTC


I've been under the impression that this key in the database section of PB.ini controls whether PB IDE - DB Painter will create extended attribute tables when it connects to a DB.


I also know that the PB.INI loaded is the one copied into the user folder

 C:\Users\yakov\AppData\Local\Appeon\PowerBuilder 19.0\pb.ini

Seems like this setting is no longer supported.  Today I connected to a postgresql db using odbc using 2019 R3 with this setting and the IDE created the table despite the INI setting.

Am I missing something or is that an old flaw?


Yakov Werde



Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 18 January 2022 21:06 PM UTC
  2. PowerBuilder
  3. # 1

Hi Yakov;

  Or using the IDE, go into the DB-Painter, Design, Options and deselect the 'Use extended attributes'.

Regards ... Chris


There are no comments made yet.
Yakov Werde Accepted Answer Pending Moderation
  1. Wednesday, 19 January 2022 21:33 PM UTC
  2. PowerBuilder
  3. # 2

Hi Chris

Thanks. Must have been my confusion while testing this out

NoCatalog=1     ;  Yes we have No bananas 

This is the setting for unchecking "Use Catalog Tables"

Making sure this setting is in place for all developer IDEs before anyone uses the DB Painter will stop the tool from injecting those pbcatelog tables


PS: I've been migrating demo apps from sqlanywhere to PostGres.  In those places where my DW SQL was totally ANSI compliant, I was  OK. But I can see how it can be a serious effort for a legacy migration



  1. Chris Pollach @Appeon
  2. Wednesday, 19 January 2022 21:40 PM UTC
So is it working OK now?
  1. Helpful
  1. Yakov Werde
  2. Wednesday, 19 January 2022 21:48 PM UTC
IT was working OK before. I wasn't working OK

  1. Helpful
  1. Chris Pollach @Appeon
  2. Thursday, 20 January 2022 01:35 AM UTC
I've had a few days like that. ;-)
  1. Helpful
There are no comments made yet.
Mark Lee @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 13 April 2022 09:10 AM UTC
  2. PowerBuilder
  3. # 3

Hi Yakov,


Since you connect to PostgreSQL with ODBC driver, please set PBNoCatalog to 'YES' under [PostgreSQL] section in the pbodb.ini file in your user folder (the default path for you would be C:\Users\yakov\AppData\Local\Appeon\PowerBuilder 19.0\pbodb.ini).

According to the help documentation of this file, PBNoCatalog='YES' - do not use PowerBuilder catalogs, default is 'NO'




There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.