1. Copetti Fulvio
  2. PowerBuilder
  3. Friday, 16 November 2018

I want to install pb2017 R3LTS STD but I receive this message :

"Setup has detected that pb2017 R3 is already installed". I execute "remove all installed features" and received "The wizard was interrupted before Appeon 2017 could be completely installed".

I want to inform you that previously i make tests with version trial R2 and R3. I have uninstalled them but in my programs to remove it is always there

 

Copetti Fulvio Accepted Answer Pending Moderation
0
Votes
Undo

Thanks Chris,
I remove all pb17 references and its ok now.

 

Roland,

i don't have CCleaner but i remember it for next time.

Comment


That's excellent news Copetti ... I am super glad that this manual clean-up procedure worked for you! :-)
  1. Chris Pollach
  2. Monday, 19 November 2018
There are no comments made yet.
  1. Monday, 19 November 2018
  2. PowerBuilder
  3. # 1
Roland Smith Accepted Answer Pending Moderation
0
Votes
Undo

The program CCleaner (previously Crap Cleaner) has the ability to delete items from the installed programs list. Then you can run the registry cleanup a couple times until it doesn't find any issues.

Comment
There are no comments made yet.
  1. Friday, 16 November 2018
  2. PowerBuilder
  3. # 2
Chris Pollach Accepted Answer Pending Moderation
1
Votes
Undo

Hi Copetti;

   This is rare, but I had been in the same situation when testing Alpha & Beta releases of Appeon PB and then trying to install the GA version later on. Even though I did an "uninstall" of those previous release/version (and even sometimes when the uninstall completed successfully) - the O/S seems to think that its still there and the new installer won't run because it thinks the current version is installed.

    Here is what I have done in that this case to resolve the "catch 22" situation like this ...

  1. Remove all PB 2017 folders via File Manager  ... "C:\Program Files (x86)\Appeon\PowerBuilder 17.0" and "C:\Program Files (x86)\Appeon\Shared" and their sub-folders.
  2. Run REGEDIT utility and remove all PB2017 references (a bit time consuming)
  3. Reboot your PC

After the above, I have been able to now install OK. The same for PowerServer.

HTH

Regards ... Chris

 

Comment
There are no comments made yet.
  1. Friday, 16 November 2018
  2. PowerBuilder
  3. # 3
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.