1. Juan Carlos Rojas
  2. PowerServer Web
  3. Tuesday, 14 August 2018

Hello. I´m following a tutorial about web services: https://www.appeon.com/developers/library/videos/soap-web-service-crash-course.html when I try to deploy, appears this message "00906: You need to configure a proper database connection for the application before deploying it." I don't know what´s the problem I reviewed the connection and tested and it works fine.

 

Thanks.

Accepted Answer
Marco Meoni Accepted Answer Pending Moderation
0
Votes
Undo

Hello Juan Carlos,

you are trying to deploy the PowerServer WS client application but forgot to configure a proper DB profile (supposedly against the PB Demo ASA database) in the PowerServer toolkit application profiles configuration page.

Here you can see the error description:

https://www.appeon.com/support/documents/appeon_online_help/pb2017r2/appeon_troubleshooting_guide/ch07s02s04.html#Error00906

Best,

.m

Comment
Hello, thank you very much for your help. It's just as you tell me, I had not correctly configured the powerserver toolkit. I already did what you told me and I went a little further, however, when running the example I get the following error and I do not know if it's because I'm running the example in windows 7. Is this the reason? Can you tell me what to do again please?

The message is: "Execute call Web Service failed. Error message:AppWebService:Failed to parse Web Service! Web Service addresshttp://mmwin10/employee/n_employee.asmx?WSDL, message= The remote name could not be resolved: 'mmwin10' "

Thank you.
  1. Juan Carlos Rojas
  2. Wednesday, 15 August 2018
There are no comments made yet.
  1. Tuesday, 14 August 2018
  2. PowerServer Web
  3. # Permalink
Juan Carlos Rojas Accepted Answer Pending Moderation
0
Votes
Undo

embarassed

Comment
There are no comments made yet.
  1. Thursday, 16 August 2018
  2. PowerServer Web
  3. # 1
Appeon Support Team Accepted Answer Pending Moderation
0
Votes
Undo

Hi Juan Carlos,


Is 'mmwin10' your computer name? please using IP address to instead of computer name, and please test the link on brower on PowerServer machine and client machine directly to see if it is work well.


Regards,
ZhaoKai

Comment
There are no comments made yet.
  1. Thursday, 16 August 2018
  2. PowerServer Web
  3. # 2
Juan Carlos Rojas Accepted Answer Pending Moderation
0
Votes
Undo

 

This is the error message when I run the web service example.

Comment
There are no comments made yet.
  1. Wednesday, 15 August 2018
  2. PowerServer Web
  3. # 3
Appeon Support Team Accepted Answer Pending Moderation
0
Votes
Undo

Hi Juan Carlos,

Please go to Toolkit > Configure > Application profile > DB Settings > Database Type to make sure you had checked correct database type, and please full deploy application.

Regards,
ZhaoKai

Comment
Please excuse me. It was a misconception. Thank you very much again for your help. My example now works correctly.

Thank you.
  1. Juan Carlos Rojas
  2. Thursday, 16 August 2018
Hello,

sorry for the late answer, mmwin10 is obviously the hostname of the server in the video.

You must replace that name with your hostname or IP address.

Best,

.m
  1. Marco Meoni
  2. Friday, 17 August 2018
Do not worry, someone helped me and I knew the reason for the problem. I also answered saying that it was a failure of my concept. Thank you. I take this opportunity to tell you that I am still following your tutorial and I have a question. In the code of the buttons you never put a return statement and the functions work correctly. When I replicate the code that you show us in the video, PB demands a return statement. In the case of the function called of_getemployees for example, your code does not have a return, why does it compile? I do not know.

Thank you.
  1. Juan Carlos Rojas
  2. Tuesday, 21 August 2018
There are no comments made yet.
  1. Wednesday, 15 August 2018
  2. PowerServer Web
  3. # 4
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.