1. Thomas Rolseth
  2. SnapDevelop
  3. Wednesday, 20 May 2020 17:22 PM UTC

We have migrated our web api to SnapDevelop 2.0.  It runs on a Windows 10 machine using an Oracle 11g database.  The api method below worked fine in SnapDevelop 1.0 but now after the migration we are getting the attached exception. During the migration we found that we could not use the Datawindow Converter with an 11g database so we came up with a workaround for that by connecting to a shell 12c database that only had the schema.  

Is the issue we are experiencing here due to the fact that SnapDevelop 2.0 does not support Oracle 11g?  I looked at the definition for ExecuteProcedure and it doesn't appear to have changed.

Thanks, Tom

public void GetItemDescription(double? ad_param1, string as_param2, int? ad_param3, string as_table, out string as_description)
            var procedureName = "CONVERT_LONGS";

            as_description = String.Empty;

            // Sets the parameter values.
            var id1 = ParamValue.New<double?>("id1", ad_param1);
            var id2 = ParamValue.New<string>("id2", as_param2);
            var id3 = ParamValue.New<int?>("id3", ad_param3);
            var table = ParamValue.New<string>("table_name", as_table);
            var output = ParamValue.New<string>("outDesc", ParameterDirection.Output);

            var result = _dataContext.SqlExecutor.ExecuteProcedure(procedureName,id1, id2, table, id3, output);

            as_description = output.Value.ToString();

Attachments (1)
Logan Liu @Appeon Accepted Answer Pending Moderation
  1. Thursday, 21 May 2020 05:00 AM UTC
  2. SnapDevelop
  3. # 1

Hi Thomas,

According to the exception message, a parameter value type may be incorrect. I can't see the definition of your stored procedure. Please double-check them again.

You can also verify whether the same code works well with Oracle12c.

If it still can't be solved. Please report a SnapObjects bug in the Appeon Standard Support at https://www.appeon.com/standardsupport/. 




  1. Thomas Rolseth
  2. Friday, 22 May 2020 14:34 PM UTC
I logged this as a bug (4681) and included a solution that you use to test with.

Thanks, Tom
  1. Helpful
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.