1. ephraim ben-eliezer
  2. SnapDevelop
  3. Friday, 24 April 2020 18:15 PM UTC

I made a simple Web API project in SnapDevelop.   It built fine and I tested it.   I then Opened it in Visual Studio 2019 and built it and deployed it to Azure.   Now I come back and try to open it in SnapDevelop and I get the following error:

Package Antlr4.Runtime.Standard, version 4.7.2 was not found.  It might have been deleted since NuGet restore.  Otherwise, NuGet restore might have only partially completed, which might have been due to maximum path length restrictions.

See attached screenshot.

I tried going to Nuget and getting that package but it didn't seem to help.

Any ideas how to help this?

Attachments (1)
Accepted Answer
Michael Kramer Accepted Answer Pending Moderation
  1. Saturday, 25 April 2020 21:48 PM UTC
  2. SnapDevelop
  3. # Permalink

4.7.2 sounds like .NET Framework

Are you sure your SnapDevelop IDE environment has access to .NET Framework 4.7.2 SDK?

  1. Logan Liu @Appeon
  2. Sunday, 26 April 2020 17:30 PM UTC
4.7.2 is a version of Antlr4.Runtime.Standard package:


  1. Helpful
There are no comments made yet.
ephraim ben-eliezer Accepted Answer Pending Moderation
  1. Monday, 27 April 2020 13:09 PM UTC
  2. SnapDevelop
  3. # 1

That gave me a clue.  I was loading the project in Visual Studio on another machine.   I installed Visual Studio 2019 Preview on the same machine a SnapDevelop and it solved the problem I think.


There are no comments made yet.
Logan Liu @Appeon Accepted Answer Pending Moderation
  1. Sunday, 26 April 2020 17:49 PM UTC
  2. SnapDevelop
  3. # 2

Hi Ephraim,

Have you ever tried running "dotnet restore" command (https://docs.microsoft.com/en-us/dotnet/core/tools/dotnet-restore) to this project and check the message?

If this issue is still existing, kindly please report this issue via our support ticketing system to ensure it is being properly tracked at https://www.appeon.com/standardsupport/.



There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.