1. Brage Mogstad
  2. PowerBuilder
  3. Thursday, 28 March 2019 10:50 AM UTC

I'm experiencing very slow performance in displaying resultsets in dwo's on my computer if I run it through RDP (remote desktop).
The retrieve itself is lightning fast, but the displaying many rows in absolutely all dwo's in my app is becoming VERY slow. 

1000 rows display instantly
2000 rows few sec
5000 rows 30+ sec (WOAH!!)
10000 rows 3 min
20000 rows 15 min

Without RDP, run locally, it is very fast.

I've turned off antivirus, no inheritance or extra code involved, simply a settransobject + retrieve and that's all. 

PB facts:
Appeon Powerbuilder Standard Edition
Version 2017 R3 Build 1858

PC facts:
It's a Intel Core i7 3740QM CPU 4 core 8 threads processor @ 2.70GHz, 24 GB of 1600Hz SDRAM memory with an Win 10 64 bits operating system and all data running on a 1GB's tuned Samsung SSD disk. It should all be more than fine AFAIK, and it is, as long as I dont run it through RDP.

Task manager tells me one processor is working at 95-100% while the 7 others rest at 5%. Memory is fine, GPU is fine. But the whole PC slows down and everything is incredibly slow from start to end of displaying the retrieved data. 

Brage Mogstad 
Maritech Systems AS


Accepted Answer
Brage Mogstad Accepted Answer Pending Moderation
  1. Thursday, 28 March 2019 14:18 PM UTC
  2. PowerBuilder
  3. # Permalink

I've tested this through all kinds of RDP settings and resolutions, through PB or through compiled exe + dll, and its still extremely slow. If I remote same PC through Teamviewer or Logmein, it's as quick as a flash. This actually has to be a RDP related issue. Probably only sollution is a bugfix from PB Appeon. Actually, as it turns out, reinstalling windows on the Surface Pro was the sollution.


There are no comments made yet.
Olan Knight Accepted Answer Pending Moderation
  1. Thursday, 28 March 2019 16:22 PM UTC
  2. PowerBuilder
  3. # 1


The retrieve does not seem to be the issue, it's how the data is displayed to the user that taking more time the more rows you retrieve from the database.

This is entirely normal.

Have you tried displaying as needed; meaning using the RETRIEVE AS NEEDED option on the DW.



  1. Brage Mogstad
  2. Friday, 29 March 2019 08:10 AM UTC
Yeah, of course it's entirely normal. But this is a Appeon PB dwo-control and dwo that works as it should, except when its run on RDP (Remote desktop connection) . Perhaps I was not clear in my description. It ONLY runs slow in RDP environment - other than that works just as excpected. I think this is some kind of setting or probably a bug.

  1. Helpful
There are no comments made yet.
Brad Mettee Accepted Answer Pending Moderation
  1. Thursday, 28 March 2019 13:35 PM UTC
  2. PowerBuilder
  3. # 2

Are you using any global functions to "paint" the datawindow, or validate data? 
Do you have a large number of complex computed expressions?
Large number of visible/invisible objects?
Resized objects or bands?

Basically, anything which causes repaints of the displayed DW on the screen is going to cause some slowdowns. In an RDP session, this will be more visible. What happens if you dw_1.SetRedraw(False) before beginning of the retrieve, and turn it back on when it's done?

  1. Brage Mogstad
  2. Thursday, 28 March 2019 13:51 PM UTC
Nope, nothing extra, plain SQL retrieve, no global functions, no computed columns, all visible objects, no extra processing in datawindow or datawindowobject.

SetReDraw() before after had no effect. It is actually a lightening fast retrived to a datastore, or to a datawindowcontrol as long as its not run through RDP. I cant find out why PB goes bullistic on processor CPU for minutes when this retrieve fires. its a 4k RDP connection through a 1000Mbit LAN. Bandwith is not an issue.
  1. Helpful
  1. Chris Pollach @Appeon
  2. Thursday, 28 March 2019 14:15 PM UTC
Sounds like it's the all around the use of RDP. Maybe someone can jump in here with some RDP "words of wisdom" and suggested settings to overcome this issue (which I suspect are GUI resources).
  1. Helpful
  1. Brage Mogstad
  2. Friday, 29 March 2019 13:52 PM UTC
As I investigated further, I found other computers actually did not experience this lag-problem using RDP to servers. I reinstalled the OS on the Microsoft Surface Pro on wich I was running the RDP connection, and that actually solved the case. Some config or some windows file must have been corrupted, or somehow overloaded.


  1. Helpful
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.