1. Alex Hernandez
  2. SnapDevelop
  3. Tuesday, 25 May 2021 08:49 AM UTC


I've just created a WebAPI project in SnapDevelop (2019 R3), and as it opens I get these errors. It seems that it does not find SnapObjects library and I have not found how to deal with this.

I tried to add a DataContext file just to test connection and a Datawindow model to see how it works, but I get the same errors even with more libraries:


Kind regards.



Alex Hernandez Accepted Answer Pending Moderation
  1. Thursday, 27 May 2021 07:50 AM UTC
  2. SnapDevelop
  3. # 1

Hi Logan,

Thank you for your response.

1) I can access this url in a web browser, but it seems that SnapDelevop cannot, as I have one error about this:

2) Yes, nuget.org is checked in the package resources list:

3) The same error when restoring tha packages:

So here's the issue, my SnapDelevop cannot connect to nuget.org but I don't know why. I've read about this error and I've not found the solution:

- I'm not using a proxy and there's nothing wrong in the nuget.config file

- I'm on a Windows 7, so I don't have a Windows 10 registry key to modify

- Nuget cache deleted, didn't worked.

- I have some applications done in Visual Studio 2015, I have no issues there with nuget





There are no comments made yet.
Logan Liu @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 26 May 2021 05:52 AM UTC
  2. SnapDevelop
  3. # 2

Hi Alex,

1) Can you access https://api.nuget.org/v3/index.json from this computer? All NuGet packages (including SnapObjects libraries) can be downloaded from nuget.org by default. 

2) Please check your package sources to see whether nuget.org is checked, refer to:


3) Right-click on your solution, select Restore NuGet Packages, then check the message in Output.



There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.