1. shoaib siddiqui
  2. PowerBuilder
  3. Thursday, 08 February 2018

good morning,

I cannot connect to PowerServer from PB or  Verify from browser.

after installation documentation suggests to test i.e. (http://10.218.41.151:80/AEM/) but I always get...

This site can’t be reached

10.218.41.151 refused to connect. Tried both https and https.

-------------------------

From PB side, I tried from powerserver profile manager , still cannot connect

Error 02012 Cannot connect to PowerServer '10.218.41.151'

 

Configuration:
Appeon PowerBuilder Universal Edition 
Version 2017 R2 1756, windows 7 
PowerServer installed on Windows 2008 server R2 

 

Marco Meoni Accepted Answer Pending Moderation
0
Votes
Undo

Hello Shoaib,
first off, do you get IIS welcome screen at http://10.218.41.151?
If not, re-install IIS first.

If you do then let’s verify if any missing PowerServer’s requirements:

  • the AEM folder must have full access rights for IIS_IUSRS user. Right-click on it (from IIS console or from Windows Explorer wwwroot\AEM) and go to Security tab;
  • from the IIS console, select the AEM application and click on “Advanced Settings...”. Be sure that the AppeonAppPool is selected.

Cheers,
.m

Comment
Thanks Marco, No I dont get welcome screen, just the error, So I un installed and Installed Powerserver  on Windows2008 Server, IIS is already installed on this server and currently serving other apps for other developers without issues. Also confirmed that AEM folder has full rights and AppeonAppPool is selected.



Then I have tried with server name instead of IP address ( http://engbld.dot.nc.net/AEM/) in chrome and got blank page no error.

But my issues is I cannot create a profile in PowerSever Profile Configuration screeen in powerbuilder, after entering Server name and Port.

then I clicked "Test PowerServer Settings.." button and got error 02012: Cannot connect to PowerServer 'engbld.dot.nc.net'



fyi: It's not letting me paste screen-shot here.



 







 

  1. shoaib siddiqui
  2. Friday, 9 February 2018
Hi Shoaib,



Please try the following and let us know if this worked.











Possible Cause









1) The server name, port or password is incorrect.



2) The Deployment Security setting in AEM is enabled.









Solution









Please check that the Appeon Server server name and port. If deployment security in AEM is enabled, you must also check the deployment username and password.











 



Another thing is to see if all configurations, features and settings for IIS are correct:



 





Install IIS





IIS is not installed on Windows 7 or 8.1 by default. You need to manually install it. Before you install IIS make sure you have installed .NET Framework 4.x, for Windows 8.1 please go to the Turn Windows features on or off and check the box for .NET Framework 4.5; for Windows 7, please download the setup program from http://www.microsoft.com/en-us/download/details.aspx?id=17718 and install .NET Framework 4.0.



Below are steps for installing IIS.



Step 1: Click Start and then click Control Panel. In Control Panel, click Programs and then click Turn on or off Windows features.



Step 2: Select the check box of Internet Information Services, then expand the list and select the items under Web Management Tools, Application Development Features and Common HTTP Features according to the figure below. Click OK to let Windows finish the install.





Figure 17. Select the Web Management Tools













 





Figure 18. Select the Application Development Features













 





Figure 19. Select the Common HTTP Features













 



Step 3: After IIS is installed, go to IIS Manager, right click the Default Web Site, select Binding, and make sure IP Address is indicated with an asterisk "*". If not, please click Edit and select All Unassigned for the IP address, this will display IP Address as an asterisk "*".



Step 4: Run http://IP_Address:80/ in Internet Explorer. If the IIS welcome screen displays, then IIS is working properly.



TIP: to obtain the IP address of the server, open a command prompt window and then type ipconfig. Remember this IP address as it is also needed when you configure the mobile app in Appeon Workspace.



If IIS is not working, please re-install IIS or fix the IIS configuration by following the IIS help.



 



Regards,

  1. Govinda Lopez
  2. Friday, 9 February 2018
 



This is my welcome page after installing PowerServer on IIS (blank) , I am not sure if it suppose to show more info.







in PowerServer config dialogue screen I get this message:



 



 







 



if this helps, this my screen looks like in IIS side:



 







 

  1. shoaib siddiqui
  2. Monday, 12 February 2018
There are no comments made yet.
  1. Friday, 9 February 2018
  2. PowerBuilder
  3. # 1
Govinda Lopez Accepted Answer Pending Moderation
0
Votes
Undo

Hi Shoaib,

 

I would recommend you to make sure that IIS is started and running correctly. Also make sure that Firewall rules allow communication through the port 80 (or whatever port you configured). It seems that your OS is refusing the connection.

 

 

Regards,

Comment
There are no comments made yet.
  1. Thursday, 8 February 2018
  2. PowerBuilder
  3. # 2
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.