1. Nathalie Meurant
  2. PowerBuilder
  3. Monday, 6 September 2021 07:53 AM UTC

Bonjour,

j'ai plusieurs applications en Powerbuilder 2017 R3.

Parmi ces applications, j'ai une seule qui se freeze de façon aléatoire et de façon intempestive. 

J'ai remarqué que cela se prodduisait lorsque la température du processeur est supérieur ou égale à 65°.

Pourquoi j'ai ce problème avec une seule application? 

Comment je peux faire pour trouver l'élément déclencheur? 

La différence avec les autres applications est qu'elle tourne en 64bits et pas en 32bits.

Je suis sous win10.

Pouvez-vous m'aider s'il vous plait?

Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 7 September 2021 16:32 PM UTC
  2. PowerBuilder
  3. # 1

Salut Nathalie;

   Ce problème de gel se produit-il sur d'autres machines ?

   De plus, lorsque l'application arrête le traitement, si vous entrez dans le Gestionnaire des tâches et passez à l'EXE de l'application, sélectionnez "GoTo Details" ... sur quoi le système d'exploitation W10 attend-il ?

Cordialement ... Chris

Comment
There are no comments made yet.
Miguel Leeuwe Accepted Answer Pending Moderation
  1. Monday, 6 September 2021 17:32 PM UTC
  2. PowerBuilder
  3. # 2

Hi Nathalie,

I don't think 65° is a very high temperature for a CPU, so I don't think that's the problem.

- Check the windows event viewer

- check how much memory is available when running the application

- check if there's something that's locking your application by going to the task manager, right click on the application, click on "go to details" and click on "analyse wait chain".

It's very difficult to give you advice on this, because there's very little information. Maybe it could have something to do with a missing runtime (like for example richtext control which is frequent) or maybe a wrong driver (like database driver not being 64 bit).

You might try to compile the application as a 32 bit executable if you thing that that could be the problem.

regards.

Comment
  1. Miguel Leeuwe
  2. Monday, 6 September 2021 18:14 PM UTC
It could also be a "timeout" and getting disconnected from the database.
  1. Helpful
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.
We use cookies which are necessary for the proper functioning of our websites. We also use cookies to analyze our traffic, improve your experience and provide social media features. If you continue to use this site, you consent to our use of cookies.