1. Nathalie Meurant
  2. PowerBuilder
  3. Monday, 6 September 2021 07:53 AM UTC

Bonjour,

j'ai plusieurs applications en Powerbuilder 2017 R3.

Parmi ces applications, j'ai une seule qui se freeze de façon aléatoire et de façon intempestive. 

J'ai remarqué que cela se prodduisait lorsque la température du processeur est supérieur ou égale à 65°.

Pourquoi j'ai ce problème avec une seule application? 

Comment je peux faire pour trouver l'élément déclencheur? 

La différence avec les autres applications est qu'elle tourne en 64bits et pas en 32bits.

Je suis sous win10.

Pouvez-vous m'aider s'il vous plait?

Miguel Leeuwe Accepted Answer Pending Moderation
  1. Monday, 6 September 2021 17:32 PM UTC
  2. PowerBuilder
  3. # 1

Hi Nathalie,

I don't think 65° is a very high temperature for a CPU, so I don't think that's the problem.

- Check the windows event viewer

- check how much memory is available when running the application

- check if there's something that's locking your application by going to the task manager, right click on the application, click on "go to details" and click on "analyse wait chain".

It's very difficult to give you advice on this, because there's very little information. Maybe it could have something to do with a missing runtime (like for example richtext control which is frequent) or maybe a wrong driver (like database driver not being 64 bit).

You might try to compile the application as a 32 bit executable if you thing that that could be the problem.

regards.

Comment
  1. Miguel Leeuwe
  2. Monday, 6 September 2021 18:14 PM UTC
It could also be a "timeout" and getting disconnected from the database.
  1. Helpful
  1. Nathalie Meurant
  2. Tuesday, 14 December 2021 08:41 AM UTC
Hi,

Indeed it s not the problem the high temperature.

I did also a 32 bit executable and i had the trouble.

Best regards

Nathalie
  1. Helpful
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 7 September 2021 16:32 PM UTC
  2. PowerBuilder
  3. # 2

Salut Nathalie;

   Ce problème de gel se produit-il sur d'autres machines ?

   De plus, lorsque l'application arrête le traitement, si vous entrez dans le Gestionnaire des tâches et passez à l'EXE de l'application, sélectionnez "GoTo Details" ... sur quoi le système d'exploitation W10 attend-il ?

Cordialement ... Chris

Comment
  1. Nathalie Meurant
  2. Tuesday, 14 December 2021 08:40 AM UTC
Bonjour Chris,

Nous savons reproduire le problème sur toute machine possédant un win10.

Quand je vais sur le gestionnaire de tâche, l'application se débloque automatiquement. D'ailleurs que j'aille sur n'importe quel application, celle-ci est débloqué.

J'ai effectué un executable sur 32 bit et j'ai le même problème. Je vais effectuer une video comme cela c'est plus représentatif.

Bien à vous

Nathalie
  1. Helpful
  1. Chris Pollach @Appeon
  2. Tuesday, 14 December 2021 17:12 PM UTC
Salut Nathalie;

Êtes-vous sur la dernière version de PB2017R3 - "build" numéro 1915 ?

Cordialement ... Chris
  1. Helpful
  1. Nathalie Meurant
  2. Thursday, 16 December 2021 08:27 AM UTC
Hello, oui tout à fait
  1. Helpful
There are no comments made yet.
John Fauss Accepted Answer Pending Moderation
  1. Tuesday, 14 December 2021 22:41 PM UTC
  2. PowerBuilder
  3. # 3

Bonjour Nathalie -

Le problème se produit-il lorsque vous exécutez l'exécutable sur le PC qui contient l'IDE PB ? Si ce n'est pas le cas, le problème peut provenir d'une DLL d'exécution provenant d'un autre numéro de version/version/build. Veuillez vous assurer que les machines qui présentent le problème utilisent les mêmes DLL d'exécution que la machine de développement.

Cordialement, Jean

Comment
  1. Nathalie Meurant
  2. Thursday, 16 December 2021 08:29 AM UTC
Bonjour, Il se produit sur la machine qui possède l'IDE PB et aussi sur celle qui n'en n'ont pas.
  1. Helpful
There are no comments made yet.
Nathalie Meurant Accepted Answer Pending Moderation
  1. Friday, 17 December 2021 09:18 AM UTC
  2. PowerBuilder
  3. # 4

Bonjour, 

voici une vidéo qui démontre mon problème de freeze. 

J'ai déjà essayé de mettre de setredraw(true) et de mettre des setfocus mais rien à faire ça freeze encore.

Je ne sais plus quoi faire. 

Aidez-moi, s'il vous plait!

Attachments (1)
Comment
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.