1. Aimee Stephens
  2. PowerBuilder
  3. Friday, 14 July 2023 12:38 PM UTC

I'm trying to add OAuth to our application for a new client. I ran the Google example through the PB IDE with no issues. However, after I created a PowerClient app the system crashes as soon as it attempts to call the WebBrowserSet or WebBrowserGet functions. We had a demo of PowerServer but we aren't ready to go that route yet and we were informed that we can perform OAuth through PowerClient. No error is returned and because it works through the IDE I don't know what could possibly be wrong. Any advice would be greatly appreciated.

These are the lines of code that are causing the crash when running the exe and are called in the application object's open event:

li_rc = WebBrowserSet ("UserAgent", "Chrome/113.0.5672.93")

li_rc = WebBrowserGet ("UserAgent", ls_value)

PB 2022/64-bit/Windows Server 2016

Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Friday, 14 July 2023 15:31 PM UTC
  2. PowerBuilder
  3. # 1

Hi Aimee;

  PB 2022 uses the Chromium engine "under the hood" to drive the built-in Web Browser control. My guess is that there is a conflict in this area with the Chromium supplied code in the PBVM.

  Note that in PB 2022 R2, Appeon has dropped the Chromium engine and now will be using the WebView2 engine instead. My suggestion would be to test your oAuth issue out (if you have the time) using the PB 2022 R2 Beta release.  HTH

Regards ... Chris

There are no comments made yet.
Francisco Martinez @Appeon Accepted Answer Pending Moderation
  1. Friday, 14 July 2023 14:29 PM UTC
  2. PowerBuilder
  3. # 2

Hi Aimee,

Are you including the Web Browser component in your PowerClient deployment?


  1. Aimee Stephens
  2. Tuesday, 18 July 2023 17:51 PM UTC
Hi Francisco,

I thought I had all of the components included in the test area but upon your questioning I ran the runtime packager again and it now works as expected.

  1. Helpful 1
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.