1. Alexander Skorokhodov
  2. PowerBuilder
  3. Monday, 14 September 2020 08:09 AM UTC

dear Appeon:

I found that this is a known issue, but I couldn't find the solution to it, so writing this post...

I am using a window with the embedded WebBrowser control in PB 2019 R2 app.

In my local development environment, the control  works fine, and it navigates to the desired URLs correctly.

When i release the compiled version of my app to the users, this control 

does not work anymore, and it displays a blank page instead of the web document.

Most likely, I am missing the required DLLs and/or other setup files in the release environment.

I have PBWebbrowser190.dll in the system root.

I tried to copy files from pbcef190 directory into the root, and in this case the webbrowser coredumps.

what can I try doing here?

please advise.

thank you.





Kai Zhao @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 15 September 2020 01:55 AM UTC
  2. PowerBuilder
  3. # 1

Hi Alexander,

Yes, you need to copy the entire folder ‘pbcef190’ to the released application root folder.

We suggest you use PowerBuilder Runtime Packager to package the runtime files. Please select the "WebBrowser Support" option in the PowerBuilder Runtime Packager to package the WebBrowser components (and the "pbcef190" folder) into the PowerBuilder runtime installer.


  1. Alexander Skorokhodov
  2. Tuesday, 15 September 2020 02:16 AM UTC
thank you, Zhao
  1. Helpful
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Monday, 14 September 2020 18:16 PM UTC
  2. PowerBuilder
  3. # 2

Hi Alexander ;

  The new built-in Web Browser control requires the following DLL's ( as per the PB Help ) ...

  • pbwebbrowser190.dll
  • chrome_elf.dll,
  • d3dcompiler_43.dll,
  • d3dcompiler_47.dll,
  • libEGL.dll,
  • libGLESv2.dll,
  • libcef.dll,
  • swiftshader/libEGL.dll,
  • swiftshader/libGLESv2.dll
  • and "pbcef190" folder


Regards ... Chris

  1. Alexander Skorokhodov
  2. Monday, 14 September 2020 22:13 PM UTC

Thank you for help, with you hint i was able to make the Web Browser control work in the release environment.

However, the instructions in PB Help "WebBrowser control support" section proved to be not accurate (for me).

Thats what had worked for me here:

When you release the system to the users, you have to copy the content of

C:\Program Files\Appeon\Shared\PowerBuilder folder

to the released system root folder.

If you want to use the Web Browser control, then in addition to the above, goto

C:\Program Files\Appeon\Shared\PowerBuilder\pbcef190

and copy its entire content to the system root.

Basically, you need to "lift" all files and subdirectories from ...\pbcef190 up to the system root.

I did not have to extract files from the pbcef190 subdirectories to the system root,

I preserved the structure of the pbcef190 as is.

  1. Helpful
  1. Chris Pollach @Appeon
  2. Monday, 14 September 2020 22:30 PM UTC
Hi Alexander;

That is great news. Thanks for the feedback & your comments.

All the heavy lifting & configuration should all be done by the PB Packager utility that builds an install MSI. The resulting install MSI should do all that for you. If not, please open a support ticket.

Regards ... Chris
  1. Helpful
  1. Alexander Skorokhodov
  2. Tuesday, 15 September 2020 00:46 AM UTC

thank you

frankly, i never used MSI, will try that out of curiosity.

  1. Helpful
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.