1. Rodney Ross
  2. PowerBuilder
  3. Wednesday, 05 July 2017

We currently have a client program that sends xml data to a vendor website.  This worked fine when the website accepted data using the TLS1.0 format.  On July 1, 2017, the vendor no longer supported TLS1.0 and we were informed that to continue sending data it would need be sent using TLS1.2 format only.

When we now try to send the xml data, we get the following error:

The underlying connection was closed: An unexpected error occurred on a send.

Any suggestions to resolve this error in PB12.5 classic or we can upgrade to PB2017 if there is an easier fix in that version?

Arcady Abramov Accepted Answer Pending Moderation
0
Votes
Undo

If you can do a test with a small application I would recommend it.

.NET Framework 4.0 does not support natively TLS1.2

With PB 2017 you can use higher version of the Framework and the client should be able to negotiate the communication seamlessly, may be even without additional code.  

 

Just my 2 cents...

Comment
There are no comments made yet.
  1. Wednesday, 5 July 2017
  2. PowerBuilder
  3. # 1
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Rodney;

   Is this question in regards to using the iNET object or PB's web services?

Regards ... Chris

Comment
The GetURL/PostURL functions don't support https at all. It would be a great if support were put on the enhancement list.

  1. Roland Smith
  2. Wednesday, 5 July 2017
PB web services

  1. Rodney Ross
  2. Wednesday, 5 July 2017
This is the error we get:



The underlying connection was closed: An unexpected error occurred on a send.

  1. Rodney Ross
  2. Thursday, 6 July 2017
There are no comments made yet.
  1. Wednesday, 5 July 2017
  2. PowerBuilder
  3. # 2
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.