1. 継武 董
  2. PowerBuilder
  3. Monday, 2 September 2019 14:49 PM

Hello everyone

The DBMS I'm using now is O10, the oracle client is 11g, and the database server is 12c. Officially, if the client is 11g or 12c, the DBMSs need to use ORA, so I have a few questions.

1. Why did I use O10 to connect to the database without an error?

2.The DBMS used by the system I am now involved in is O73 database server is oracle 9i. I used O10 after system migration. Will an error occur if I continue to use it?

Thank you

Olan Knight Accepted Answer Pending Moderation
  1. Tuesday, 3 September 2019 21:05 PM
  2. PowerBuilder
  3. # 1
0
Votes
Undo

Your have described the setup we currently use, and use without issues.

The advantage to continue using Oracle 12C and below, rather than the newever version fo Oracle, is that those newer versions come with "features" we don;t need or use,. and thei license fee is MUCH, MUCH, MUCH higher.

Stick with 12C and below if you can do so.


Later -

Olan

Comment
Thank you for your advice, Olan.

I will continue to use the O10 driver until need to add 11g functionality. :)
  1. 継武 董
  2. Thursday, 5 September 2019 09:05 AM
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Monday, 2 September 2019 14:57 PM
  2. PowerBuilder
  3. # 2
0
Votes
Undo

Hi;

   The older DB drivers will typically work with many newer DBMS versions. It's just that they don't support the newer features. In your case, the O10 driver only supports Oracle 10 DML. Even though your on O11G or 12C. The ORA driver will support newer DML & features in line with your newer Oracle version.

HTH

Regards ... Chris

Comment
Thank you, Chris.

I decided to use O10 because the new features of 11g or 12c were not used . :)
  1. 継武 董
  2. Thursday, 5 September 2019 09:02 AM
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.