1. James Medick
  2. PowerBuilder
  3. Wednesday, 13 February 2019 16:57 PM UTC

Is there anything special regarding using the Table Blob control?  The "How to's" that I can find don't seem to work.  I get the blob displayed sometimes but the cursor goes into a continual wait state (circle of death). 

Using MySQL, latest PB, and the document I've stored in the database is an RTF.  I would just like to store and use a word doc.  Also, using OpenOffice, not MS Word.

The blob is stored in a separate table with two columns, ID and blob.

Also, there seems to be an inconsistency between the initial definition window for specifying the blob and the definition window once the blob has been created (properties).


Accepted Answer
James Medick Accepted Answer Pending Moderation
  1. Wednesday, 13 February 2019 18:49 PM UTC
  2. PowerBuilder
  3. # Permalink

I added the parm to adjust the size although no change.  My blob is only 1.6k. 

Not sure where I find PB Help on MySql.  All I get is a "page not found" or the standard help file.

There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 13 February 2019 17:12 PM UTC
  2. PowerBuilder
  3. # 1

Hi James;

   The main thing to remember in this case is that BLOB data streams can be truncated. This is typically because the DBMS's DB Client connectivity restricts the length of the Blob result set. Often to 32K. In order to make sure that your App(s) receive the full Blob adat stream, you need to quite often set a Transaction Object's DBParm setting to have the DB Client accept a larger result set.

   For example:

SQLCA.DBParm = "DBTextLimit='90000'"    -  OR

SQLCA.DBParm="PBMaxBlobSize=1024000"  -  OR -


  The setting in the DB Client driver and/or the setting as in the examples above will depend on your DBMS, version, type of DB Client, etc. The best is to carefully read the information in the PB Help file on your specific DBMS connectivity options and in particular - specialzed Blob processing requirements. For example in ASE or SS - SQLCA.AutoCommit  = TRUE


Regards ... Chris

There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.