1. Jeffrey Alonzo
  2. PowerBuilder
  3. Thursday, 10 October 2019 20:02 PM

Hi,

 

Just want to check if PB2017 R3 has any incompatibility issues with Sybase Open Client 16.  

 

Thanks in advance.

 

Jeff

Jeffrey Alonzo Accepted Answer Pending Moderation
  1. Tuesday, 15 October 2019 18:21 PM
  2. PowerBuilder
  3. # 1
0
Votes
Undo

Hi Armeen and Chris,

 

Thank you for the replies.  We have ruled out that there is no compatibility issue.  We tested a PB app to connect to upgrade Sybase DB and found a connectivity issue.  This has been resolved by renaming libsybcs.dll and libsybct.dll to libct.dll and libcs.dll fixed the issue.

 

Thanks,

 

Jeff

Comment
Thanks for sharing the solution!
  1. Armeen Mazda @Appeon
  2. Tuesday, 15 October 2019 19:01 PM
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Friday, 11 October 2019 15:57 PM
  2. PowerBuilder
  3. # 2
0
Votes
Undo

Hi Jeff;

  I have used PB 2017 with ASE 16 for years and now with PB2019 as well with no issues. There are two considerations though when moving to the newer ASE v16/17 DBMS versions ...

1) Make sure that you use the new "ASE" DB client driver and not "SYC".

SQLCA.DBMS = "ASE"

2) Make sure that you tell the DB Client driver exactly what ASE version you are using in your DBParm field

SQLCA.DBParm = "Release='16',Async=1,DBGetTime=5,DBTextLimit='100000',TrimSpaces=0"

HTH

Regards ... Chris

Comment
There are no comments made yet.
Armeen Mazda @Appeon Accepted Answer Pending Moderation
  1. Thursday, 10 October 2019 21:52 PM
  2. PowerBuilder
  3. # 3
0
Votes
Undo

Appeon doesn’t test all different versions of drivers.  But if your Sybase DB version is listed as supported in the docs and this client was working in PB 12.x it should continue to work in PB 2019.  Just keep in mind if you compile the app to 64-bit you need 64-bit version of the driver on the user’s machine.

Comment
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.