1. Gilbert Lee
  2. PowerBuilder
  3. Tuesday, 4 September 2018 06:55 AM UTC


-SoapConnection failed-

I made deployment files via PB 2017 R3 temporally but It didn't work on Windows Server 2012 R2. It worked on my computer (Windows 7 Pro). The previous PB version was PB 11.2 and all worked well on all Windows version. I focused on pbwsclient170.pbd(x) and pbsoapclient170.pbd(x) and copy those files from 32 bit or from 64 bit but both of those tests were failed. Furthmore I copied all dll, pbd and pbx files from 32 bit or from 64bit.

Are there someone who has same issues?

Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 4 September 2018 13:53 PM UTC
  2. PowerBuilder
  3. # 1

Hi Gilbert;

  FYI:  PB 11.x web services were based on .Net 2.0 whereas in PB2017Rx they are based on .Net 4.5. So make sure that the .NET 4.x framework is installed on your target machine(s).

   In the mean time - does the WS work OK on your development PC with a local IIS installed?

TIP: If you wrap a TRY..CATCH around the WS commands, the "exception" object can often contain more information about the WS error.

Regards ... Chris


There are no comments made yet.
Gilbert Lee Accepted Answer Pending Moderation
  1. Wednesday, 5 September 2018 02:04 AM UTC
  2. PowerBuilder
  3. # 2

Hi Chris,


.NET 4.0 was installed on all computers but it didn't work on only 2012 R2.

Thank you for your answers.


There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.