1. David Peace (Powersoft "The PowerBuilder & C# People")
  2. SnapDevelop
  3. Wednesday, 23 June 2021 11:06 AM UTC

I'm using SnapDevelop 2019R3 Build 2703. I cannot connect to MS SQL Server. I get network connectivity error and a timeout. I can connect to the same database using PB IDE on the same Wind 10 PC.

I've checked that required protocols are enabled o nthe SQL Server and the firewall will allow the inbound connections.

What am I missing?

Cheers

David

Accepted Answer
Sivaprakash BKR Accepted Answer Pending Moderation
  1. Thursday, 24 June 2021 08:44 AM UTC
  2. SnapDevelop
  3. # Permalink

Hello,

To connect SQL Server with instance name from SnapDevelop 2703

1.  First we need to connect SQL Server without instance name (eg.  computername instead of computername\instancename)

How to do it ?

a.  In the SQL Server configuration Manager, under SQL Server Network Configuration -> Protocols for SQL2012 -> Right Click TCP/IP -> Change TCP port to 1433 for IPAll

2.  Open port in Firewall for 1433 port

3.  Restart SQL Server, if required.

4.  Try connecting SQL Server from SQL Management studio with computername alone, not with instance name (eg.  mycomputer instead of mycomputer\instancename)

5.  Now try connecting from SnapDevelop (with computername alone).

6.  See no other instances of SQL Server running in that machine.

It's working for me.

 

Comment
  1. Armeen Mazda @Appeon
  2. Friday, 25 June 2021 16:35 PM UTC
It is on the roadmap that SnapDevelop 2021 support connecting to the instance name. So once you upgrade you should be able to have this option.
  1. Helpful
  1. Sivaprakash BKR
  2. Saturday, 26 June 2021 06:56 AM UTC
Armeen,

You mean, 2019 R3 LTS version won't have this bug fixed ?

  1. Helpful
  1. Armeen Mazda @Appeon
  2. Saturday, 26 June 2021 07:21 AM UTC
It’s not a bug. We didn’t support this way of connecting.
  1. Helpful
There are no comments made yet.
Sivaprakash BKR Accepted Answer Pending Moderation
  1. Thursday, 24 June 2021 13:36 PM UTC
  2. SnapDevelop
  3. # 1

Filed a bug report with Appeon, let's see what they say.

https://www.appeon.com/standardsupport/track/view?id=6840

 

Comment
  1. David Peace (Powersoft "The PowerBuilder & C# People")
  2. Thursday, 24 June 2021 13:42 PM UTC
Yes, the whole SQL Server connection seems a little clunky also having to fix the port may not be acceptable in some instances.
  1. Helpful
There are no comments made yet.
  1. Thursday, 24 June 2021 09:08 AM UTC
  2. SnapDevelop
  3. # 2

Thank you for your help, this resolved my problem.

Comment
There are no comments made yet.
Armeen Mazda @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 23 June 2021 14:52 PM UTC
  2. SnapDevelop
  3. # 3

Hi David, Have you enabled BOTH TCP and Named Pipes in SQL Server?  SnapDevelop requires this.

 

 

Comment
  1. David Peace (Powersoft "The PowerBuilder & C# People")
  2. Wednesday, 23 June 2021 15:09 PM UTC
Hi Armeen

Yes both are enabled and I manually set the port to 1433 just to be sure :)
  1. Helpful
There are no comments made yet.
Francisco Martinez @Appeon Accepted Answer Pending Moderation
  1. Wednesday, 23 June 2021 13:09 PM UTC
  2. SnapDevelop
  3. # 4

Hi, David!

Can you share your connection settings?

Regards,
Francisco

Comment
  1. Francisco Martinez @Appeon
  2. Wednesday, 23 June 2021 16:34 PM UTC
Here are the details on connecting using sqlcmd https://docs.microsoft.com/en-us/sql/ssms/scripting/sqlcmd-connect-to-the-database-engine?view=sql-server-ver15 in case you're wondering what's the correct way to write the host



I'm still trying to figure out the issue, but it seems like the problem is not inside SnapDevelop. I'll keep digging around
  1. Helpful
  1. Francisco Martinez @Appeon
  2. Wednesday, 23 June 2021 20:10 PM UTC
Hi David, the connectivity issue you describe is too broad, I think. Here's a Microsoft troubleshooting page addressing connectivity issues to the server, please take a look a it: https://docs.microsoft.com/en-us/sql/database-engine/configure-windows/troubleshoot-connecting-to-the-sql-server-database-engine?view=sql-server-ver15

Please let me know if that isn't enough to help you sort out the issue
  1. Helpful
  1. David Peace (Powersoft "The PowerBuilder & C# People")
  2. Thursday, 24 June 2021 09:07 AM UTC
Thank you for your help. Yes if sqlcmd does not connect it's got nothing to do with SnapDevelop. I resolved the problem by not connecting using the instance name. As theer was only 1 instance on this server it did not matter, but may do if there are multiple instances.
  1. Helpful
There are no comments made yet.
Roland Smith Accepted Answer Pending Moderation
  1. Wednesday, 23 June 2021 12:49 PM UTC
  2. SnapDevelop
  3. # 5

I had the opposite problem, I couldn't connect from PowerBuilder. In MSSMS I had to bring up user mapping and check the AdventureWorks2012 database so I could connect and db_owner role so I could see the tables.

Comment
  1. David Peace (Powersoft "The PowerBuilder & C# People")
  2. Wednesday, 23 June 2021 12:57 PM UTC
Hi Roland, yes I saw that thread... unfortunately it didn't help?
  1. Helpful
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.