1. Ganne Gannene
  2. PowerServer Web
  3. Tuesday, 16 January 2018

Hi to all !

I deploy my desktop app to web application, but Appeon Deployment Wizard write:

14:18:19 00005: Failed to parse the source code. Line: 6
14:18:19 Failed to parse UserObject n_cpp_smtp.

 

is there an pb web app example to send mail?

 

Thanks in advance

Gianna

Appeon Support Team Accepted Answer Pending Moderation
0
Votes
Undo

Hi,

Please refer to the article below for how to send SMTP emails from a PowerBuilder application.
https://support.appeon.com/index.php?/Knowledgebase/Article/View/128/0/sending-smtp-emails-from-powerbuilder-applications

And please note that some features are supported by PowerServer Web but unsupported by PowerServer Mobile. If you want to run application on web only, please make sure the project type is ‘Web’ (PowerServer Toolkit> Application Profile Configuration> Basic Settings), thus the unsupported features report would only include the unsupported features by PowerServer Web (the report will include the unsupported features by Web and Mobile if the project type is ‘Both’).

Regards,

Comment
Hi,



It is work well on our end. what's the PB version and PowerServer version you are using? do all machines have same issue?



Please note it is work on 32-bit IE but not 64-bit IE, you can test on Chrome too. please give a try with our application URL below.

http://demo.appeon.com/smtp

  1. Appeon Support Team
  2. Thursday, 18 January 2018
Hi, on Chrome it is work well!



thank you so much !

  1. Ganne Gannene
  2. Friday, 19 January 2018
Hi,



Here is a solution to open 32-bit IE, please give a try.



Step1: In the registry , change the value of HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\TabProcGrowth to the value greater than 0.

Step 2: Restart the IE.

For more details please refer to:

http://support.microsoft.com/kb/2716529



Reards,

ZhaoKai

  1. Appeon Support Team
  2. Monday, 22 January 2018
There are no comments made yet.
  1. Wednesday, 17 January 2018
  2. PowerServer Web
  3. # 1
mike S Accepted Answer Pending Moderation
0
Votes
Undo

 smtp:

http://www.topwizprogramming.com/freecode_emailsmtp.htm

 

outlook via ole:

http://anvil-of-time.com/wordpress/powerbuilder/powerbuilder-reading-outlook-items/

Comment
Hi Mike !





It Does not work when I deploy a web application (getaddrinfo return code 11003).



Have you got any suggestion?



Thanks in advance 

  1. Ganne Gannene
  2. Tuesday, 16 January 2018
you are using PBNI - which doesn't work with web



use the SMTP code that doesn't use pbni and just calls the windows APIs from pb



 



 



 

  1. mike S
  2. Tuesday, 16 January 2018
I have download your link from topwizprogramming. Desktop version is ok (works fine).





It Does not work when I deploy a web application (getaddrinfo return code 11003) of it.



 



 

  1. Ganne Gannene
  2. Tuesday, 16 January 2018
There are no comments made yet.
  1. Tuesday, 16 January 2018
  2. PowerServer Web
  3. # 2
Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Gianna;

   Looks like your using an object that probably has some low-level code in it to try & use SMTP features. The SMTP commands probably do not translate to JavaScript - hence the parsing error(s). If you still want to continue using SMTP from your Web Apps - you could instantiate the SMTP object in a PB Web Service and then call it from your Web App.

   The other alternative is to use the PB built-in Mail commands. Appeon supports MAPI (messaging application program interface), so you can enable your Web applications to send and receive messages using any MAPI-compliant email system.

Regards ... Chris

Comment
Hi Chris, I'm using pbnismtp.pbx .. 



I still want to continue using SMTP, have you got a sample code of it?

where can I find an example?



Thanks in advance



 



 

  1. Ganne Gannene
  2. Tuesday, 16 January 2018
There are no comments made yet.
  1. Tuesday, 16 January 2018
  2. PowerServer Web
  3. # 3
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.