1. Brad Morrow
  2. PowerBuilder
  3. Monday, 18 June 2018

We have recently migrated our PB8 application to PB2017.  We have a few datawindows that were created as RichText.  When we try to retrieve the data the data is returned but not displayed in the report.  It is also does not print, just spaces where the retrieved data should be.  I tried creating a new RichText datawindow thinking that maybe it had to with the migration but the same things happen.  I have looked around the forums but was unable to find what I am missing.  I am hoping someone out there that can help point me in the right direction.

Thanks!

Chris Pollach Accepted Answer Pending Moderation
0
Votes
Undo

Hi Brad;

  FYI: Open the PB2017 Rx HELP file that comes with the IDE and then review carefully the section  .... 

  • What's New =>  New Features in PowerBuilder 2017 => New RichTextEdit control

    The old 3rd party TX control was replaced by another 3rd party RTE control called the TE Control. The TE Control has some differences. You may have to refactor your PowerScript code in order to comply. This also affects the RichText DW as well.

Note1: In the Application object, you have the ability of selecting the TX Control if you wish to purchase it separately and still run the old control "under-the-hood".

Note2: Appeon is planning to include the old TX Control in PB 2018. The developer will then have the choice of using either one.

Regards ... Chris

Comment
As Chris mentioned, PB 2018 will include special OEM version of the old TX TextControl for backwards compatibility.  As such, no separate purchase will be required.

  1. Armeen Mazda
  2. Tuesday, 19 June 2018
Sounds like you might not have a property (or more) on a column(s) or on the RT DW itself set 100%. Maybe that is what is causing your RT issues (just a guess).

  1. Chris Pollach
  2. Tuesday, 19 June 2018
I am having the same problem as Brad outlined above with the Rictext datawindow. Doing an Insertdocument and a retrieve. Record is retrieved but is not displayed in the report. Does this work or am I missing something. Works fine in PB12.5. Like Brad I recreated the datawindow and still doesn't work.

Thanks
  1. al Torchetti
  2. Wednesday, 22 August 2018
There are no comments made yet.
  1. Monday, 18 June 2018
  2. PowerBuilder
  3. # 1
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.