1. Sabir Foux
  2. PowerServer Obsolete (2020 or older)
  3. Sunday, 8 September 2019 02:28 AM UTC

Problem: The web app we've deployed to localhost on our virtual server cannot make a Rest call. It returned with status code -1 but returns no status code text.

Question: Has anyone encountered a RestClient status code of -1 with no status code text returned with it?

Note: It works just fine when running the app from the PowerBuilder IDE.

 

This one has me stumped. Mostly because RestClient.GetResponseStatusText() is returned empty when it makes a call to the third party api I'm using. However when I click the run window button in the powerbuilder IDE it works just fine.

 

Thank you for any advice, tips, or suggestions you may have.

Accepted Answer
Sabir Foux Accepted Answer Pending Moderation
  1. Sunday, 8 September 2019 16:34 PM UTC
  2. PowerServer Obsolete (2020 or older)
  3. # Permalink
0
Votes
Undo

I switched from RESTClient to HTTPClient. HTTPClient works so I'll use that.

Comment
There are no comments made yet.
Kai Zhao @Appeon Accepted Answer Pending Moderation
  1. Monday, 9 September 2019 01:42 AM UTC
  2. PowerServer Obsolete (2020 or older)
  3. # 1
0
Votes
Undo

Hi Babir,

Please note that the restclient is supported by Appeon Web but unsupported by
Appeon Mobile. If you want to run application on web only, please make sure the
project type is ‘Web’ (Toolkit > Configure > Application Profile Configuration>
Basic Settings), thus the unsupported features report would only include the
unsupported features by Appeon Web (the report will include all the unsupported
features by Web and Mobile if the project type is ‘Both’).

Regards,
ZhaoKai

Comment
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.