1. Andres Slachevsky
  2. PowerBuilder
  3. Wednesday, 28 February 2018

My customer have decided to go for:
one PowerServer Enterprise and one PowerServer Developer

but they will keep their application in PB12.5 for at least this year

Following the documentation i found:
https://www.appeon.com/support/documents/appeon_online_help/2017/installation_guide/bk01ch01s03.html

Not PowerServer Entreprise nor PowerServer developer provide PowerServer Toolkit

So my question is how i will install the toolbar of PowerServer in Powerbuilder

In the documentation i found:

https://www.appeon.com/support/documents/appeon_online_help/2017/installation_guide/bk01ch03s02s03.html

 

mike S Accepted Answer Pending Moderation
0
Votes
Undo

to deploy to powerserver you must install pb2017

you can develop in 12.x  , but when you deploy to powerserver you must start pb2017 and run the toolbar from there.

you do not need to migrate your application to 2017

Comment
There are no comments made yet.
  1. Wednesday, 28 February 2018
  2. PowerBuilder
  3. # 1
Marco Meoni Accepted Answer Pending Moderation
0
Votes
Undo

Hello Andres,
if you use PB 12.5 you need Appeon Server 2016 (or older).

The documentation you mentioned refers to Appeon PowerServer 2017.
You cannot deploy to PowerServer 2017 (Mobile /Web) from PB 12.5.


So, to recap:
1) have your PB 12.5 box ready;
2) install Appeon 2016 workgroup/developer edition, in there you can select the toolkit

Best,
Marco

Comment
There are no comments made yet.
  1. Wednesday, 28 February 2018
  2. PowerBuilder
  3. # 2
Michael Hartnett Accepted Answer Pending Moderation
0
Votes
Undo

Hi Andres,

I believe that the toolkit will only work with the latest version of PB 2017 if you are planning to use PowerServer.  These products go hand in hand.  The latest toolkit cannot be installed in older versions of Powerbuilder.

See replies in this existing post...https://community.appeon.com/index.php/qna/q-a/help-installing-powerserver-tookit-in-old-pb-version

You would need to migrate the project to PB 2017 in order to deploy to PowerServer.  Alternatively, you could purchase and use an Appeon 2016 server license, which will work.

Michael

Comment
There are no comments made yet.
  1. Wednesday, 28 February 2018
  2. PowerBuilder
  3. # 3
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.