1. Krithika BS
  2. PowerBuilder
  3. Thursday, 18 February 2021 08:03 AM UTC

Hello,

I installed 2017R3 and 2019R3 in the same computer.   Couldn't I login into both version simultaneously ?  When I contact the support, I get the following reply.  I thought with the release of 2019R3 I could login to both version simultaneously.

***********************************************
Hi Keccu,

The current version of PowerBuilder 2017 R3 doesn’t support using the same license with PowerBuilder 2019 R3 simultaneously.

Please try log out PowerBuilder 2017 R3 and then log into PowerBuilder 2019 R3.

Regards,
Tom Jiang

**************************************************

Is it so ?

regards
BS Krithika

 

Armeen Mazda @Appeon Accepted Answer Pending Moderation
  1. Monday, 22 February 2021 01:24 AM UTC
  2. PowerBuilder
  3. # 1
3
Votes
Undo

Hi Krithika, We are synchronizing the license mechanism change to PB 2017 R3 in the next MR (maintenance release) that is scheduled around early April.  Soon this annoyance will be gone.

Comment
There are no comments made yet.
Kevin Ridley Accepted Answer Pending Moderation
  1. Friday, 19 February 2021 14:23 PM UTC
  2. PowerBuilder
  3. # 2
1
Votes
Undo

This is a known issue until you get to PB2019 R3+ for the Appeon apps.  In the meantime try what Rene mentioned below.  Open up 2 copies of PB 2017, then logout (but don't close) one.  Then you will be able to open PB 2019.  It's not ideal having to keep the logged out one opwn, but it will allow you to have both 2017 and 2019 opened at the same time.

 

Kevin

Comment
There are no comments made yet.
René Ullrich Accepted Answer Pending Moderation
  1. Thursday, 18 February 2021 09:44 AM UTC
  2. PowerBuilder
  3. # 3
1
Votes
Undo

Hi Krithika,

There is a change of license check in PB 2019 R3. But PB 2017 doesn't kknow about it. ;-)

You may try to start PB 2017 first and than PB 2019 (I don't know if this works).

Or you use the old live hack: Start PB 2017 twice. Logout from one instance. Start PB 2019.

I think (hope) we will no habe such problems if we only use versions after PB 2019 R3.

HTH,

René

Comment
All applications developed in PB 2017 will take at least 3-5 years to be upgraded to PB 2019. FYI.
  1. Krithika BS
  2. Friday, 19 February 2021 05:32 AM UTC
Are you using PB 2027 R3?
  1. Armeen Mazda @Appeon
  2. Friday, 19 February 2021 14:27 PM UTC
Hi Marc, We are synchronizing the license mechanism change to PB 2017 R3 in the next MR (maintenance release) that is scheduled around early April. Soon this annoyance will be gone.
  1. Armeen Mazda @Appeon
  2. Monday, 22 February 2021 01:24 AM UTC
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.