1. Sébastien Levasseur
  2. PowerBuilder
  3. Monday, 27 September 2021 12:02 PM UTC

Hi team,

Hi migrated an IDE application since PB 12.5 to 2019 R3.

When I execute this application on Windows 10 physical workstation, there are no problem.

But when I execute the same binary on Windows 10 virtual session with Citrix, this application crash with Windows Visual C++ runtime error (error message in attachment) one which screen (particularly when I exit windows with datawindow in update on database).

Have you ever meet this issue, how I can fix this one?

Thank you for your help.

 

Regards

Sebastien Levasseur

sebastien.levasseur@ubs.com

Attachments (1)
Who is viewing this page
Miguel Leeuwe Accepted Answer Pending Moderation
  1. Thursday, 30 September 2021 10:28 AM UTC
  2. PowerBuilder
  3. # 1

Have a look at https://community.appeon.com/index.php/qna/q-a/error-r6025-in-pb2019r2-beta

There might be a useful link there.

regards.

Comment
There are no comments made yet.
Mark Lee @Appeon Accepted Answer Pending Moderation
  1. Thursday, 30 September 2021 02:21 AM UTC
  2. PowerBuilder
  3. # 2

Hi Sebastien,

 

1. I just need you to confirm again that you have modified the pb.ini file under the same directory where your exe resides.  

If not, please add a pb.ini file to the directory where the EXE resides and this file should contain the following content.

Then run it again and see if it works well. 

[Data Window]

ACCESSIBILITY=0

You can refer to the following link for details about how to set the ACCESSIBILITY feature:

https://www.appeon.com/developers/get-help/knowledgebase/powerbuilder-datawindow-hangs-temporarily-after-retrieve.html  

 

2. Since I can't reproduce your issue locally, I can only provide some troubleshooting steps for you.

One customer of ours had the application crashing issue in Citrix previously and they solved the issue by the solution in the links below. So I suggest you try it and see if the issue is gone.

https://support.citrix.com/article/CTX107825

https://support.citrix.com/article/CTX232495

 

3. Is your application a 64-bit application? If you deploy it as a 32-bit application, can you still reproduce it (I just want to confirm whether it is related to the platform)?

 

If the issue persists after doing the above, I suggest you report this problem to our ticket system: https://www.appeon.com/standardsupport/newbug so that it can be properly received and tracked. Please also provide a sample PB test case (with PBT / PBL) when you submit it to the ticket system. Thanks in advance.

 

Regards,

Comment
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Monday, 27 September 2021 18:53 PM UTC
  2. PowerBuilder
  3. # 3

Hi Sebastien;

  Did you install the "Microsoft Visual C++ 2010 x86 Redistributable" software on your Citrix environment?

Regards .... Chris

PS: "Microsoft Visual C++ 2010 x64 Redistributable" if you are deploying 64bit PB App EXEs.

Comment
  1. Sébastien Levasseur
  2. Tuesday, 28 September 2021 08:56 AM UTC
Hi Chris,



The soft seems installed (see attached file at this conversation)



Regards

Sébastien
  1. Helpful
There are no comments made yet.
Armeen Mazda @Appeon Accepted Answer Pending Moderation
  1. Monday, 27 September 2021 18:30 PM UTC
  2. PowerBuilder
  3. # 4

Have you tried disabling accessibility in your PB.INI

ACCESSIBILITY=0

Comment
  1. Sébastien Levasseur
  2. Tuesday, 28 September 2021 08:58 AM UTC
Hi Armeen,



After test this adding on INI file is without effect and the issue persist.



Regards

Sébastien
  1. Helpful
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.