1. Nils-Erik Sundeberg
  2. PowerBuilder
  3. Monday, 12 February 2018 10:22 AM UTC

I get this error when I run orcascr170.exe via the tfs 2017 build server:
Appeon (R) OrcaScript interpreter version 17.0
    Using ANSI source file _build_2017.dat.
Start Session
scc get connect properties "..\pbl125\log4pb.pbw"
scc set connect property logfile "build.log"
scc connect
   Orca error in 'scc connect '. Result Code -26.
   SCC Open Project failed for project
   Scc OpenProject failed.
Last Command Failed.
scc close
You must successfully issue scc connect before you can call this method.
End Session

The "build.log" file looks like this:
2018-02-12   10:54 Source Management Initialization...
Nonspecific Error performing SccOpenProject.
Source control is in offline mode.

When I run it "manually" from a cmd window it works fine. I can even run it as the same user that runs the TFS service.

I have upgraded my (very small = 1 pbl) application to PB 2017.

Someone who has a clue? What does Code -26 mean exactly?



David Peace (Powersoft) Accepted Answer Pending Moderation
  1. Wednesday, 14 February 2018 11:54 AM UTC
  2. PowerBuilder
  3. # 1

"When I run it "manually" from a cmd window it works fine. I can even run it as the same user that runs the TFS service."

What do you mean by this? If it works from a CMD window then I suggest that there is a permissions issue which the environment in which you the error. Run as administrator?

  1. Nils-Erik Sundeberg
  2. Wednesday, 14 February 2018 14:07 PM UTC
What I mean is that I can run orca-commands as an interactive user, from a cmd window. The user is the same that runs the tfs agent. The user is also Admin so I can't see that it has to do with permissions. I get the error when I run the command from tfs build server.

  1. Helpful
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Monday, 12 February 2018 14:43 PM UTC
  2. PowerBuilder
  3. # 2


  Can you give us some more information about this ...

1) What build of PB 2017 are you using?

2) What SCC system are you working with?

3) Are you running ORCAScript on your development PC?

Regards ... Chris

  1. Govinda Lopez @Appeon
  2. Monday, 12 February 2018 18:26 PM UTC
Hi Nils-Erik,


Have you tried with the latest version/build of PowerBuilder? The build 1666 is not the latest one. You can download PowerBuilder 2017 R2 from your User Center at https://www.Appeon.com or you can download the latest build for PowerBuilder 2017 (build 1681).


Please let us know if this worked for you.



  1. Helpful
  1. Nils-Erik Sundeberg
  2. Tuesday, 13 February 2018 08:31 AM UTC
I have now upgraded Powerbuilder to build 1681 and after that reinstalled the Autocompiler from the new build, ie new version of pbc170.exe and orcascr170.exe.

I still get the same error when triggering my build from Tfs 2017.

I have also tried to set up a task with the Task Scheduler in Windows and running the same orca command from there and still getting the same error.

Running from a cmd window still works fine.


  1. Helpful
  1. Nils-Erik Sundeberg
  2. Wednesday, 14 February 2018 07:40 AM UTC

Hi Chris,

1) I have upgraded to build 1681 of PB 2017

2) I work with TFS 2017 (MSSCCI provider and Team Explorer 2013 installed on the build server)

3) I am running ORCAScript on a build server where I only installed the Autocompiler.

It works fine when I am logged in to  the server and run orcascr170.exe manually. But when I run through the tfs build job I get the error I described earlier.

So my question is: Is it not possible to run orascr70 on a tfs server? I also wonder if it is possible to get a more describing error message than "Code -26". It doesn't say why the project can't be opened.

  1. Helpful
There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.