1. Tracy Lamb
  2. PowerBuilder
  3. Thursday, 12 May 2022 13:14 PM UTC

In my dw, I have a column that requires the user to double-click to select a value from another table (Search screen).  This works great, but before the Select response window displays, I get a message "Value Required for this Item"... twice.  How can I disable this message when I'm double-clicking to open a response window?

On a related note, how can I disable this Required Value check until I actually save the dw?  I'm using PB2021 and the most recent PFC.


Who is viewing this page
Accepted Answer
Olan Knight Accepted Answer Pending Moderation
  1. Thursday, 12 May 2022 13:51 PM UTC
  2. PowerBuilder
  3. # Permalink

Are you using the PFC's Required Column service?
If so, unregister this particular column from the service and control it yourself in the SAVE event; i.e. the pfc_save event if you are using the PFC.

Also check the DW itself. Look at the column properties to ensure there is nothing in the ATTRIBUTE columns (bottom center pane of the DW painter).

  1. Tracy Lamb
  2. Thursday, 12 May 2022 15:24 PM UTC
Thank you. I'm not using the PFC Required Column service. I changed the Edit properties for that column in the dw, unchecked the Required box. And, I check for a value in the pfc_preupdate event. Everything works fine now.
  1. Helpful
There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Thursday, 12 May 2022 15:22 PM UTC
  2. PowerBuilder
  3. # 1

Hi Tracy;

   You may have to ...

A) Disable the DW Control on the first mouse click as your App code is opening the Response window to avoid unwanted behaviour. Then enable the DC after the Response window closes to prevent double double-clicking events from being fired.

B) Use the DC's Modify() command to disable the "Required" column check just before opening the Response window. Then restore this DWO setting(s) upon Response window closure.

Regards ... Chris

There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.