1. David Vasconcelos
  2. PowerServer Web
  3. Thursday, 20 September 2018

We have an application build in PB2017 and converting to PowerServer Web, If I wanted to use the ldap function (appeonldaplogon) from the appeon workaround pbl's do I need to configure the AEM server security for LDAP?

 

 Additional info... here is the error I get when I try to use it.

 

I have also tried using Chris P. STD library, works fine in PB client server but I get a connection error in appeon web

ll_rc = lole_ad.ConnectToNewObject ( ls_server ) //"MSScriptControl.ScriptControl" 

I get a -3  (not able to connect)..

Thanks for any ones help.

IF anyone has a different solution on how to connect to LDAP/AD from Powerserver Web let me know.

Dave v.

Accepted Answer
David Vasconcelos Accepted Answer Pending Moderation
0
Votes
Undo

Zhao, thanks for letting me know that I need to configure LDAP on AEM if I want to use the appeonldaplogon function.  I do want to clarify something you said, since this app would mostly be running on the WEB ( I do want to keep the option of running as Client Server as a backup) then the following statement should have worked in both powerbuilder Client Server and WEB

 

ll_rc = lole_ad.ConnectToNewObject ( ls_server ) //"MSScriptControl.ScriptControl" 

 

is that correct?

If so any ideas why it is not working on the Web side or any direction on troubleshooting it.

(project type is set to Web)

 

Thanks for your time

Dave V.

Comment
Hi Dave;

Zhao Kai is correct, the OLE aspects of PB are only supported in the WEB mode of PowerServer. I like to suggest to any PS developers that they do NOT use the "both" option in the PS App Profiles. I would recommend that you create two PS profiles: one for Web Deployment and one for Mobile Deployment. When you set the project type to "both", the PS Toolkit compiler takes the lower featured support route. In your case, the OLE feature is not supported in the Mobile environment - thus, the jScipt code is not generated fully for that feature.

HTH

Regards ... Chris
  1. Chris Pollach
  2. Friday, 21 September 2018
See my reply.. not sure if you get an email if I "reply" or "add Comment"
  1. David Vasconcelos
  2. Friday, 21 September 2018
Yes, I do. Note that LDAP OLE support may need to be installed (ADSI) and will not work unless the PC that is running the native or web app is running on a network "Domain". Also, the LDAP support I have is for Microsoft's A.D.
  1. Chris Pollach
  2. Friday, 21 September 2018
There are no comments made yet.
  1. Friday, 21 September 2018
  2. PowerServer Web
  3. # Permalink
David Vasconcelos Accepted Answer Pending Moderation
0
Votes
Undo

Hi Chris, 

I think maybe there is some confusion... when I meant "both" I mean running it as a normal PowerBuilder application and a Powerserver Web application, since development is done in PowerBuilder then converted to PowerServer (Web).  We are not deploying Mobile (cell phones).  Basically all I want to do is connect to LDAP in order to confirm users access.  When I use the OLE method it works in PowerBuilder build, but when converted into PowerServer Web the OLE does not connect.  Hope I am getting the terminology correct regarding PowerBuilder vs PowerServer Web.

So if I am understanding correctly... the following OLE connection should work for both PowerBuilder and Powerserver Web. Is that correct?

ll_rc = lole_ad.ConnectToNewObject ( ls_server ) //"MSScriptControl.ScriptControl" 

If it is correct then I am having an issue because I get a return code of -3 (not able to connect) on the above code.

Hopefully I am not being dense on this and just not getting it.

Any help would help at this point.

Thanks

Dave V.

 

Comment
I did not try that, thanks, I was thinking maybe I was being blocked by some security or internet setting on the browser and that could be why the OLE connection is not working. I will give that a try once I get into the office. Dave V. Out of curiosity what would be the best/normal way to access LDAP from a PowerServer Web App,
  1. David Vasconcelos
  2. Friday, 21 September 2018
I use a Web Service for that normally. The WS also then works for PS Mobile Apps as well. ;-)
  1. Chris Pollach
  2. Friday, 21 September 2018
That was also suggested (Plan C or D) if you don't mind me asking which service are you using and is there a cost?

Definitely thanks for your answers...very much appreciated.
  1. David Vasconcelos
  2. Friday, 21 September 2018
There are no comments made yet.
  1. Friday, 21 September 2018
  2. PowerServer Web
  3. # 1
Zhao Kai Accepted Answer Pending Moderation
0
Votes
Undo

Hi David,

To use appeonldaplogon function, you are required to configure the AEM server security for LDAP.

The OLE object supported by PowerServer Web but unsupported by PowerServer Mobile. If you want to run application on web only, please make sure the project type is 'Web' (PowerServer Toolkit > Configure > Application Profile Configuration> Basic Settings), thus the unsupported features report would only include the unsupported features by PowerServer Web (the report will include all the unsupported features by Web and Mobile if the project type is 'Both').

 

Regards,
ZhaoKai

Comment
There are no comments made yet.
  1. Friday, 21 September 2018
  2. PowerServer Web
  3. # 2
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.