1. Danish Ahamed LiakathAli
  2. PowerBuilder
  3. Friday, 26 February 2021 18:57 PM UTC

Hi ,

    I am trying to create and deploy  our application using new Power Client feature. I find little hard time to get it done. 

1. Libraries :- I am not able to choose or map the PBR file under Libraries Tab - I have a resource file stored under the respective pbl folder. When i click the browse button it is pointing only my Application Target path pbl and not able to choose any other path

 

2. External Files Tab :- I am not able to use the DLL & OCX registration . When I click i don't find anything to choose. 

   

   same with loading INI configuration file.

 

 

Samething when adding a files under new package folder. It directs to the Application Target Pbl folder path but not allow to choose any other folder. 

I am not sure I am missing any steps . My PB version/build details below.

 

Any advices would be really appreciated. 

Kai Zhao @Appeon Accepted Answer Pending Moderation
  1. Monday, 1 March 2021 07:29 AM UTC
  2. PowerBuilder
  3. # 1
1
Votes
Undo

Hi Danish,

For the select files issue:
You can only select files from the current application folder. Please make sure all files are placed in the same folder or sub-folder of the application target (.pbt) file. You can find this information in PowerBuilder online help below.
https://docs.appeon.com/pb2019r3/pbug/ch07s03.html#defining_an_ica_project

For the DLL & OCX registration and INI configuration issue:
Please make sure you have added dll & ini files into Files preloaded in uncompressed format section in External Files Tab .

Regards,
ZhaoKai

Comment
I followed the steps and I am able to load/edit the files.
  1. Danish Ahamed LiakathAli
  2. Monday, 1 March 2021 20:11 PM UTC
There are no comments made yet.
Danish Ahamed LiakathAli Accepted Answer Pending Moderation
  1. Friday, 26 February 2021 20:39 PM UTC
  2. PowerBuilder
  3. # 2
0
Votes
Undo

Yes I do. Start the PB using RunAs A Adminstrator, 

Comment
There are no comments made yet.
Armeen Mazda @Appeon Accepted Answer Pending Moderation
  1. Friday, 26 February 2021 20:26 PM UTC
  2. PowerBuilder
  3. # 3
0
Votes
Undo

Do you have admin rights on this machine and did you start PowerBuilder using the "Run as Administrator" option?

Comment
A co-worker was showing me this very issue not more than 10 minutes prior to Danish's post! That's kind of spooky. I've not used PowerClient (yet), but it sounds like PC requires all resources be located in or under the same folder as the target, which is NOT how everyone organizes their app components.
  1. John Fauss
  2. Friday, 26 February 2021 21:02 PM UTC
Hi John;

As Armeen eluded to ... for PowerClient and PowerServer2021 (Cloud Apps), you must be able to run the PB IDE "As Admin" to use these features.

For the resources all under the same "Root" folder of the App Workspace ... you are absolutely correct in R3's current implementation.

Regards .... Chris
  1. Chris Pollach @Appeon
  2. Friday, 26 February 2021 21:20 PM UTC
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this question yet.
However, you are not allowed to reply to this question.