1. Ian Wells
  2. PowerBuilder
  3. Tuesday, 1 June 2021 00:30 AM UTC

Hi All, me again (sorry).

Trying to get the PowerClient working. I'm using IIS Express on the local machine. After deploying the PowerClient Project successfully, I click the "Run PowerClient Project button in the PowerBar" (I'm following the tutorial here): 


Edge Browser opens. and I get:


Hmmm… can't reach this page

localhost refused to connect.


Screenshot attached of the Edge page error
I believe it is trying to get to http://localhost/AIMS

I have attached a screenshot of the running IIS Express command window. It mentions a port number: 8080. Is that significant?

Thanks in advance for your help.






Attachments (2)
Armeen Mazda @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 1 June 2021 02:44 AM UTC
  2. PowerBuilder
  3. # 1

Yes, the port number IIS is configured to listen to is important.  Your URL needs to have port 8080 in it.

I would recommend you approach this systematically.  First, use a Web browser and see if you can even connect to IIS without using PowerClient or trying to click the shortcut in the PowerBuilder IDE.  So enter http://localhost:8080 in Web browser and you should see IIS welcome page.  If you do not, your IIS is not configured correctly and you should refer to Microsoft documentation how to setup IIS.

If it is working, then I would check in IIS Manager what is the Web root that is mapped to your port 8080.  Usually the default is c:\inetpub\wwwroot, but you should double-check.  I've seen lots of people overlook silly things and waste tons of time and frustration.

Next, you configure your PowerClient app to deploy to the path of the Web root that is mapped to your port 8080.  After you do the deploy, you need to go to the file system and make sure you see the folder with your app name and inside that folder has various files.

Then you open a Web browser and type http://localhost:8080/AIMS/  If you've followed the above steps as I have said, there is extremely high chance you will not get the page not found error.

On a side note, you need to make sure that when you start the PowerBuilder IDE you do the right-click "Run as Administrator" option.  Otherwise, some features of the PowerBuilder IDE is not going to work properly, such as deploying your PowerClient app to IIS.

There are no comments made yet.
Chris Pollach @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 1 June 2021 02:05 AM UTC
  2. PowerBuilder
  3. # 2

Hi Ian;

  Make sure that "localhost" has been added to your internet settings "trusted" sites.

Regards ... Chris

There are no comments made yet.
  • Page :
  • 1

There are no replies made for this question yet.
However, you are not allowed to reply to this question.