1. Thomas Rolseth
  2. PowerBuilder
  3. Tuesday, 14 December 2021 06:34 AM UTC

I am having issues running a lightweight PB application called CRH that has been deployed to a remote Amazon AWS server.  The app was built with PB 2021 build 1288 and uses SQL Server for the database.  The deployment goes fine and I can download and install the Cloud App Launcher (CAL) on the client machine (my laptop).  I can run the application on the server itself w/o issue and when I enter the external IP address of the server in chrome on my laptop, I get the IIS default page.  So the server is reachable and running normally.  The AWS server is Windows Server 2019 and the client is running Windows 10.

When I download the CAL, I get a Windows Defender warning but am able to continue past this and install it.  It shows up in Control Panel as part of my installed programs.  Thinking a security issue might be the issue and after reading other posts in this forum, I did the following:

  1. Signed the exe with a Comodo code signing cert
  2. Signed the CAL with a Comodo code signing cert
  3. Selected the Embedded Manifest option
  4. I'm using the Default_WithoutService option

None of the above have helped.  When I look at the properties of the exe and CAL, I can see my cert attached.  What happens is that after the CAL installs, nothing happens when I click 'Start Application' button.  Doing so pops up a dialog where I have two options -- 'Open App Launcher' or 'Cancel'. Clicking either does nothing other than close the popup.  If I hover my mouse over the 'Start the Application' button, you will see the following flash in the lower left of the browser:


If I move the mouse off the button it will just flash 'Connecting...' over and over.  I need to validate that a PB app will run properly when deployed to a remote server via PowerClient (and ultimately PowerServer) so any help with would be greatly appreciated.

Note:  I also tried running the application in chrome on a new pristine laptop and it didn't work there either -- same issue.  I've redeployed the app several times after wiping things out on the AWS server and have rebooted the server several times as well.  No joy...

Thanks, Tom

Attachments (1)
Accepted Answer
Kai Zhao @Appeon Accepted Answer Pending Moderation
  1. Tuesday, 14 December 2021 07:59 AM UTC
  2. PowerBuilder
  3. # Permalink

Hi Thomas,

Does the application work well on Firefox/IE? If only Chrome/Edge have the
issue, it should be caused by an Chromium security update, please refer to article below to solve it.


  1. Thomas Rolseth
  2. Tuesday, 14 December 2021 15:39 PM UTC
I had tried IE/Edge with same issue but that was before I signed everything with a Comodo cert. The app does work in IE and Firefox -- I use those two so infrequently that I didn't consider them and the majority of end users will rely on Chrome or Edge. In addition, it works now in Chrome after disabling the CORS flag. So for Chrome, it sounds like the best long-term solution is to get an SSL cert on the AWS web server?
  1. Helpful
  1. Kai Zhao @Appeon
  2. Wednesday, 15 December 2021 01:16 AM UTC
Hi Thomas,

Glad to hear that it works in Chrome now. Currently, installing the SSL cert on the AWS web server is the better solution.

BTW, PowerBuilder 2022 will refactor the Could App Launcher to avoid this issue.



  1. Helpful
There are no comments made yet.

There are replies in this question but you are not allowed to view the replies from this question.